Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

3. Даны два неравных числа X и Y. Большее из них заменить на сумму этих чисел, а меньшее увеличить в три раза.

10-11 класс

4. Известны периметр первого треугольника Р1, координаты вершин второго x1, y1, x2, y2,x3, y3 и длины сторон третьего – а3, в3, с3. Найти и вывести на экран периметр меньшего треугольника.

Алгоритмы ветвления

Matushevich 09 февр. 2015 г., 6:58:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dima25258635
09 февр. 2015 г., 8:06:32 (9 лет назад)

3.
uses crt;
var x,y:integer;
begin
read(x,y);
if x>y then
begin
x:=x+y;
y:=y*3
end
else
begin
y:=x+y;
x:=x*3
end;
writeln(x,' ',y);
end.
4.
uses crt;
var p1,p2,p3,x1,y1,x2,y2,x3,y3,a3,b3,c3:real;
begin
writeln('Введите P1,x1,y1,x2,y2,x3,y3,a3,b3,c3:');
read(p1,x1,y1,x2,y2,x3,y3,a3,b3,c3);
p2:=(sqrt( (x2-x1)*(x2-x1) + (y2-y1)*(y2-y1) ) ) + (sqrt( (x3-x2)*(x3-x2) + (y3-y2)*(y3-y2) ) ) + (sqrt( (x3-x1)*(x3-x1) + (y3-y1)*(y3-y1) ) );
p3:=a3+b3+c3;
writeln(min(min(p1,p2),p3));
end.

Ответить

Другие вопросы из категории

Написать

программу, которая подсчитывает количество отри­цательных элементов в заданном
массиве a, размерностью n.

помогите плиз сделать 2,3,4)))
написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Читайте также

1)По данному числу n вычислите сумму 2(1-1/3+1/5-1/7+...+(-1)n/(2n+1)). Формат входных данных: Вводится одно число n, не превосходящее 100000.

Формат выходных данных: Необходимо вывести значение выражения 2) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b,не дающие остаток c при делении на d 3) Подсчитайте, сколько среди данных N чисел нулей, четных чисел, нечетных чисел. Вводится число N, а затем N чисел. Необходимо вывести сначала число нулей, затем число четных и нечетных чисел 4) электронное устройство, выдает каждую секунду очередное число последовательности 1, 2, 2, 3, 3, 3, 4, 4, 4, 4, 5... Ввиду дороговизны электронных комплектующих вам поручено разработать эмулятор для этого устройства. Формат входных данных: Дано количество секунд (от 1 до 1000000), которые работает генератор после включения. Формат выходных данных: Результат работы генератора(пример 2 1 2 5 1 2 2 3 3) 5)Вклад в банке составляет x рублей. Ежегодно он увеличивается на p процентов, после чего дробная часть копеек отбрасывается. Каждый год сумма вклада становится больше. Определите, через сколько лет вклад составит не менее y рублей.Программа получает на вход три натуральных числа: x, p, y и должна вывести одно целое число 6)Исполнитель “Раздвоитель” преобразует натуральные числа. У него есть две команды: “Вычесть 1” и “Разделить на 2”, первая команда уменьшает число на 1, вторая команда уменьшает число в два раза, если оно чётное, иначе происходит ошибка.Дано два натуральных числа A и B (A>B). Напишите алгоритм для Развоителя, который преобразует число A в число B и при этом содержит минимальное число команд. Команды алгоритма нужно выводить по одной в строке, первая команда обозначается, как -1, вторая команда как :2.

Даны два целых

числа A и B (A < B). Вывести все целые числа,
расположенные между данными числами (включая сами эти числа), в порядке их
возрастания (убывания), а также количество N этих чисел (с использованием
оператора for, while, repeat)

Даны два действительных числа X и Y, не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением.

Разработать схему алгоритма для решения этой задачи. Протестировать алгоритм на числах 5.5 и -4.3, а также на числах 1 и 14.5.

Два натуральных числа называются "дружественными", если каждое из них равно сумме всех делителей другого, за исключением его самого (таковы, например,

числа 220 и 284). Напечатать все пары "дружественных" чисел, не превосходящих заданного натурального числа. (Определить функцию, вычисляющую сумму делителей числа.)сделать в C# (си шарп)Помогите пожалуйста)



Вы находитесь на странице вопроса "3. Даны два неравных числа X и Y. Большее из них заменить на сумму этих чисел, а меньшее увеличить в три раза.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.