Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Найти количество целых трехзначных чисел, произведение цифр которых равно N(вводится с клавиатуры). создать программу на Паскале

5-9 класс

Pascal2012 29 окт. 2014 г., 14:01:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lolamirova
29 окт. 2014 г., 15:11:59 (9 лет назад)

var

  n, i, count : integer;

begin

  read (n);

  for i := 100 to 999 do

    if (i div 100) * (i div 10 mod 10) * (i mod 10)  = n then

      inc (count);

  writeln (count);

end.

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА ПОМОГИТЕ НАПИСАТЬ ПРОГРАММУ ОТ НАЧАЛА ДО КОНЦА !!!

ОЧЕНЬ СРОЧНО!
Напишите программу, которая получив число ,выводит на экран соответствующий день недели. Например, ввели число 2, программа должна вывести "вторник". Если число не выходит за пределы 1...7, то должно быть выведено сообщение , сто такого дня нет.

Нужно всё с решением.

задача № Информационное сообщение объёмом 2.5 Кбайт передаётся со скоростью 2560 бит/мин. За сколько минут будет передано данное сообщение?
задача № Средняя скорость передачи данных с помощью модема равна 36 864 бит/с. Сколько секунд понадобится модему, чтобы передать 4 страницы текста в 8-битной кодировке КОИ8, если считать, что на каждой странице в среднем 2304 символа?
задача № Сколько секунд потребуется модему, передающему сообщения со скоростью 14400 бит/с, чтобы передать сообщение объёмом 225 Кбайт?

Помогите пожалуйста !!!

Переделать слова так чтобы они подходили к слову
Бег
- - -
- - -
- - -
- - -
Шаг

Море
- - - -
- - - -
- - - -
- - - -
Суша

Миг
- - -
- - -
- - -
- - -
- - -
- - -
- - -
Век

Помогите пожалуйста !!

Читайте также

1. Производительность формовочной машины - 7 тарелок в минуту. Сколько тарелок произведут N машин за T часов?

2. Составить программу удвоения большего из двух чисел.

3. Написать программу вычисления произведения всех двузначных четных чисел.

4. Определить количество двузначных натуральных чисел, сумма цифр которых равна заданному числу N.

Все в Pascal. Очень прошу помочь

1. Квадрат трехзначного числа оканчивается тремя цифрами, которые как раз и составляют это число. Найти такие числа (например, 625: 625^2=390 625).

2. Найти сумму целых положительных чисел, больших 20, меньших 100, кратных 3 и заканчивающихся на 2,4 или 8.

Решить в Паскале

1)В диапазоне от 0 до 100 подсчитать количество чисел оканчивающихся на 3.

2)В диапазоне от 0 до 50 подсчитать количество чисел сумма цифр которых равна 3.



Вы находитесь на странице вопроса "Найти количество целых трехзначных чисел, произведение цифр которых равно N(вводится с клавиатуры). создать программу на Паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.