Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

C++. Не могу написать программу вычисляющую n степень числа a (a^n) без использования pow(x,y). Помогите пожалуйста

5-9 класс

Lukoyanova2016 06 авг. 2013 г., 18:15:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VikaGandzuk
06 авг. 2013 г., 19:11:14 (10 лет назад)

int s=a;
for(int i=1; i<n; ++i)
    s*=a;

Ответить

Другие вопросы из категории

Исполнитель Чертёжник действует на координатной плоскос­ти. У него есть перо, которое может быть поднято или опущено. При поднятом пере Чертёжник просто

перемещает­ся по плоскости; при опущенном — оставляет след в виде линии. Исполнитель может выполнять команды:
1) сместиться в точку (а, b), перемещающую Чертёжника из точки с координатами (х, у) в точку с координатами (а, b);
2) сместиться на вектор (а, b), перемещающий Чертёжника из точки с координатами (х, у) в точку с координатами (x+а, у+b).
Для повторения k раз некоторой последовательности команд используется запись:
нц к раз
команда1 команда2 командаЗ
кц
а) Определите, что будет нарисовано после выполнения Чертёжником программы:

поднять перо
сместиться в точку (3, 1)
опустить перо
сместиться на вектор (2, 0)
сместиться на вектор (1,1)
сместиться на вектор (-4, 0)
сместиться в точку (3,1)
поднять перо
сместиться на вектор (1,1)
опустить перо
сместиться на вектор (0, 3)
сместиться на вектор (1, -2)
сместиться на вектор (-1, -1)

Разгадайте и сопоставьте имена и фамилии ученых, изобретателей и программистов, внесших большой вклад в развитие информатики.

АЛАН БИЛЛ ДЖОН КАРЛ КЛОД ЛИНУС ЧАРЛЬЗ
БЭББИДЖ ГЕЙТС ЛИННЕЙ НЕЙМАН ТОРВАЛЬДС ТЬЮРИНГ ШЕННОН

в основу окрашивания каждого пикселя на экране компьютера положена;

А)собственность восприятия цвета человеческим глазом
Б)пространственное размещение монитора
В)палитра цветов монитора
Г)модель RGB
ответов может быть не сколько...
помогите пожалуйста

Читайте также

ЯЗЫК QBASIC !!! Решите задачи, используя цикл while-wend 1. Написать программу, вычисляющую сумму и среднее арифметическое последовательности

положительных чисел, которые вводятся с клавиатуры. 2. Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности неограниченна).

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

написать программу которая в последовательности натур. чисел определяет сумму всех чисел кратных 8 и оканчивающихся на 4.программа получает на вход

натур. числа а также их количество.количество чисел не превышает 1000.программа должна вывести одно число:сумму всех чисел кратных 8 и оканч. на 4
ПОМОГИТЕ, ПОЖАЛУЙСТАА

Помогите пожалуйста написать 2 программы

1)Написать программу которая меняет местами числа a и b(линейная и оператор присваивания)
2)Программа проверки существования треугольника по его 3 сторонам
Напишите пожалуйста***

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или

похудеть.по формуле рост минус 100...

написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ...(( ну ни как не могу додуматься(( помогите (( вот сама написаная программа

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
write('введите массу тела');
read(ves);
write('введите рост в см');
read(rost);
optVes:=rost-100;
if ves>optVes then write('вам необходимо похудеть' );
if ves<optVes then write('вам необходимо поправиться');
if ves=optVes then write ('ваш вес оптимальный')
End.



Вы находитесь на странице вопроса "C++. Не могу написать программу вычисляющую n степень числа a (a^n) без использования pow(x,y). Помогите пожалуйста", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.