Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составить программу решения квадратичного уравнения заданными коэфицентами a,b,c. В Паскаль.

5-9 класс

Ksy79 01 июля 2013 г., 17:02:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
миха2003
01 июля 2013 г., 18:09:38 (10 лет назад)

# -*- coding: cp1251 -*-
import math
a = float(raw_input("Введите a:"))
b = float(raw_input("Введите b:"))
c = float(raw_input("Введите c:"))
d = b*b - 4*a*c
if d < 0:
print 'нет корней'
elif d == 0:
x = -b/(2*a)
print 'x=', x
elif d > 0:
x1 = (-b + math.sqrt(d))/(2*a)
x2 = (-b - math.sqrt(d))/(2*a)
print 'x1=', x1, ' ', 'x2=', x2

 

уруру. могу только на питоне. 

паскаль долго вспоминать.

+ 0 -
Zhannapeg
01 июля 2013 г., 20:12:26 (10 лет назад)

Program blah;
Uses Crt;
Var a,b,c,x1,x2,d,x: real;
begin
Write ('Введите коэффицент a='); Readln (a);
Write ('Введите коэффицент b='); Readln (b);
Write ('Введите коэффицент c='); Readln (c);
If a=0 then
begin
x:=(0-c)/b;
Writeln ('Ответ:x=',x);
end
else
begin
d:=sqr(b)-4*a*c;
if d<0
then Writeln ('Корней нет.')
else
begin
x1:=(-b+sqrt(D))/2*a;
x2:=(-b-sqrt(D))/2*a;
if x1=x2
then Writeln ('Ответ:x=',x1) else Writeln ('Ответ:x=',x1,';',x2);
end;
end;
end.

Ответить

Другие вопросы из категории

Уточните, каков объем оперативной памяти компьютера (у меня 16 гб),к которому вы имеете доступ дома или в школе .Сколько страниц текста можно разместить в

памяти этого компьютера (на странице размещается 40 строк 60 символов в каждой строке , а для хранения одного символа требуется 8 битов)? Какой была бы высота такой стопки страниц ,если высота стопки из 100 страниц равна 1 см? Объясните пожалуйста как решить.

Дело было в Америке. Как-то раз подошли к реке англичанин, негр и индеец, каждый со своей женой. Всем нужно было переправиться на другой берег. В их

распоряжении была только одна лодка (да и та без гребца), способная вместить лишь двоих. Договорившись между собой, мужчины решили было приступить к переправе, как вдруг выяснилось, что ни одна из жен не желает переправляться в лодке с чужим мужем или оставаться на берегу в мужском обществе без своего мужа. Мужья призадумались, но все же сумели догадаться, как выполнить желание своих жен. Как они сумели переправиться через реку?

Читайте также

Прошу написать 2 рабочих программы Pascal Так что бы скопипастть в программу и не возиться, заранее благодарю 1)

Составить программу решения

линейного уравнения: ах + в = 0,

при (а <> 0)

2)

Посчитать, сколько молекул воздуха находится в данной комнате.

по поводу этой задачи от себя могу добавить (

молярная масса воздуха принимается равной 29 г/моль.
зная объем комнаты (параллелепипед высота*ширина*длина) находите объем в литрах. объем/22,4=количество в молях. полученный результат умножается на число авогадро и ответ готов (без учета давления и температуры)

надеюсь это поможет вам в составление программы и тем самым оказании услуги многим-многим школьникам, попавим в неловкое положение, в последние дни четверти.

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая:

а) определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на "Янка". Задание 3. Составьте программу, которая в строке "реки горы и болота": а) удаляет слово "горы"; б) Заменяет слово "болота" на "озера". Буду безмерно благодарна!!!

Помогите составить программу по информатике в Pascal ABC. Задание 1. С клавиатуры одной строковой вводят имя и фамилию. Составьте программу, которая: а)

определяет, есть ли в определенной строке заданный символ; б) копирует в новую строку имя и выводит его; в) выводит сначала фамилию, а затем имя. Задание 2. Составьте программу, которая в строке "Касіу Ясь канюшыну" заменяет имя "Ясь" на...



Вы находитесь на странице вопроса "Составить программу решения квадратичного уравнения заданными коэфицентами a,b,c. В Паскаль.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.