Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу на Паскале.Из элнментов данного массива W[1..20]создать два новых массива, первый из которых содержит только положительные элементы, а

5-9 класс

второй только отрицательные.

Applesmile2012 14 марта 2015 г., 7:44:55 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dasha0872
14 марта 2015 г., 9:29:23 (9 лет назад)

VAR
   i: Integer;
   a, b: Array of Integer;
   W: Array [1..20] of Integer;
BEGIN
   SetLength(a, 1); SetLength(b, 1);

   For i := 1 to 20 do Read(W[i]);

   For i := 1 to 20 do begin 
      If (W[i] > 0) then begin  
         SetLength(a, Length(a)+1); a[Length(a)-1] := W[i]; End;
      If (W[i] < 0) then begin 
         SetLength(b, Length(b)+1); b[Length(b)-1] := W[i]; End; End;

   Write('0 > ['); For i := 1 to Length(a)-2 do Write(a[i],','); Writeln(a[Length(a)-1],']');  
   Write('0 < ['); For i := 1 to Length(b)-2 do Write(b[i],','); Writeln(b[Length(b)-1],']');  
END.

Ответить

Другие вопросы из категории

101011001-11111011=?

101011001+11111011=?

дайте названия последовательностям действий (АЛГОРИТМАМ)

1. установите курсор перед 1 установить курсор за лишним символом.
2. нажать клавишу бэкспэйс . лишним символом. ----------------------------------------------
2. нажать клавишу 1 установить курсор на место вставки символ
-------- ----------- 2. нажать клавишу с нужным символом.
1 установить курсор перед ошибочным
символом.
2. нажать клавишу дел.
3. нажать клавишу с верным
символом

запишите алгоритм удаления символа с помощью клавиши бэкспэйс.
1
2
3

Читайте также

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

Помогите сослать программу на Паскале.Поиск чисел в массиве. Program Example;

{Программа заполняет массив Rand случайными числами в диапазоне от 0 до 50,
вводит число Х, и вычисляет, сколько раз Х входит в массив Rand}

Var Rand: array[1..20] of integer;
I, X, NumberX : integer,
Begin
{Установка датчика случайных чисел}
​Randomize;
{Заполнение массива случайными числами и вывод их на экран}
​Writeln(‘Массив случайных чисел:’)
​For I:=1 to 10 do
​begin
​ Rand[I]:=random(50); Write(Rand[I]:4)
​End;
​Writeln;
{Ввод Х}
​Write(‘Введите Х:’)); Readln(X);
{Подсчет числа вхождений Х в массив}
​NumberX:=0;
​For I:=1 to 10 do
​​If Rand(I)=X then NumberX:=NumberX+1;
{Анализ и вывод результата}
​If NumberX=0
​Then​writeln(‘В массиве нет числа’,X)
​Else writeln(‘Число’,X,’в массиве присутствует’,NumberX,’раза’)
End.

помогите пожалуйста с информатикой вот такие задачки:

Линейные программы.
Напишите программу на ШАЯ. Вычислите площадь боковой поверхности куба. S=4a(в квадрате)
Условный оператор (ветвление)
Нарисуйте блох-схему. Найдите решение уравнения ax+b=0 если оно отсутствует.
Циклы
Напишите программу на Паскале. Вводится последовательность из N целых чисел. Сколько отрицательных чисел и сумма положительных чисел?
Одномерные массивы
Напишите программу на паскале. В одномерном массиве вычислите сумму положительных элементов.
Двумерные массивы
Напишите программу на паскале. Дан квадратный целочисленный массив. Уменьшить в два раза все его элементы.

Если что извините, надеюсь не много прошу.

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.








Вы находитесь на странице вопроса "Напишите программу на Паскале.Из элнментов данного массива W[1..20]создать два новых массива, первый из которых содержит только положительные элементы, а", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.