Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Решите задачу d и Напишите программу на паскале

5-9 класс

Ivanshina82 18 окт. 2014 г., 20:21:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Almenov031
18 окт. 2014 г., 21:24:44 (9 лет назад)

var
  x, y, z, p, q, a: longint;
  fin, fout: Text;

begin
  Assign(fin, 'input.txt');
  Reset(fin);
  Readln(fin, z, p, q);
  Close(fin);
  Assign(fout, 'output.txt');
  Rewrite(fout);
  if z <= 1 then Writeln(fout, 'no')
  else
    if (z mod p <> 0) or (z mod q <> 0) or (p * q > z) then Writeln(fout, 'no')
    else 
      if z = p * q then Writeln(fout, p, ' ', q)
      else begin
        a := z;
        x := 1;
        while (a mod p = 0) do
        begin
          x := x * p;
          a := a div p
        end;
        a := z div x;
        y := 1;
        while (a mod q = 0) do
        begin
          y := y * q;
          a := a div q
        end;
        a := z div (y * x);
        if a = 1 then Writeln(fout, x, ' ', y)
        else Writeln(fout, 'many')
      end;
  Close(fout)
end.

Ответить

Другие вопросы из категории

Какая

операция не применяется для редактирования текста:

3 примера различных типов алгоритмов
For 2 решите пожалуйста

Читайте также

РЕШИТЕ ХОТЬ ЧТО-НИБУДЬ!!!:з 1.Линейные программы Напишите программу на ШАЯ.Вычислите значения следующих выражений: f=t*t/2+t

2.Условный оператор(ветвление)

Нарисуйте блок-схему.Дано два числа.Верно ли, что он равны?

3.Циклы

Напишите программу на Паскале. Выведите на экран табицу умножения на 4 в виде 1+4=4,2+4=8,....9*4=36.

4.Одномерные массивы

Напишите программу на Паскале.Подсчитайте количество максимальных элементов массива А [1..12].

5.Двумерные массивы

Напишите программу на Паскале. создать массив случайны чисел В[1..6,1..6].Все элементы массива, расположенные выше главной диагонали сделать равными О.Вывести исходный и исправленный массивы.

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!

Напишите программу на паскале)

1.С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.
2.С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.
3.С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.



Вы находитесь на странице вопроса "Решите задачу d и Напишите программу на паскале", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.