Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите, пожалуйста, срочно написать код на паскале! Все голову сломала:(

5-9 класс

Даны массивы Н1..Н5 шифры предприятий 1ой группы
НН1..НН8 шифры предприятий 2ой группы
N1..N5 наименование продукций предприятий 2ой группы
NN1..NN8наименование продукций предприятий 2о1 группы
Вывести списки предприятий выпускающих одинаковую продукцию

ADELINA2002 26 апр. 2015 г., 6:51:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
DaryanaS
26 апр. 2015 г., 7:23:44 (9 лет назад)

var H1:array[1..5] of integer;
    H2:array[1..8] of integer;
    N1:array[1..5] of integer;
    N2:array[1..8] of integer;
    i, j:integer;

begin
randomize;
for i:=1 to 5 do {заполняем массивы}
 begin
 H1[i]:=random(10);
 N1[i]:=random(10);
 end;
for i:=1 to 8 do
 begin
 H2[i]:=random(10);
 N2[i]:=random(10);
 end;
for i:=1 to 5 do {сравниваем продукцию}
 for j:=1 to 8 do
 if N1[i]=N2[j] then writeln(i, ' и ', j, ' Выпускают одинаковую продукц.');
write('H1 ');{выводим массивы}
for i:=1 to 5 do
write(H1[i], ' ');
writeln;
write('N1 ');
for i:=1 to 5 do
write(n1[i], ' ');
writeln;
write('H2 ');
for i:=1 to 8 do
write(H2[i], ' ');
writeln;
write('N2 ');
for i:=1 to 8 do
write(N2[i], ' ');
writeln;
end.

Ответить

Другие вопросы из категории

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА СРОЧНО

Найдите произведение цифр заданного четырехзначного числа...Сделать программу на Паскаль

Помогите пожалуйста, срочно надо.

Заранее большое спасибо)
1) Определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11.
2) Найдите и выведите на экран все двузначные числа, у которых при умножения на 2 сумма цифр увеличивается на 5.

Помогите пожалуйста срочно надо программа на англиском языке

Водится возраст человека вывести имеет ли право человека голосовать (>=18) если не имеет то вывести сколько лет ему надо подождать

Помогите пожалуйсто решить прошу очень срочно!!!!

1. Чему равны значения переменных r, a, d?
a:=5; b:=20; c:=-7;
d:=2.5;
r := a+(4*b+c)*d;
a:= a+4;
d:=a*7;

2. В пяти тестовых опросах мальчик получил оценки. Составьте программу, которая определит среднее значение оценок, полученных мальчиком в пяти опросах.

3*. Задача. «Покупка в магазине»
Человек делает в магазине покупки. Определите сколько денег у него останется после покупки в магазине перчаток стоимостью А руб., портфеля стоимостью B руб. и галстука стоимостью D руб. Все исходные данные задаются с клавиатуры.

Исходные данные.
a — стоимость перчаток;
b — стоимость портфеля;
d — стоимость галстука;
dengi — количество денег у человека.
Все эти переменные будут вещественного типа.
Результат.
ostatok — количество денег, которое останется у человек (вещественный тип).
Метод решения.
ostatok = dengi – a – b – d
Написать программу, реализующую данную задачу
Помогите пожалуйсто решить очень срочно!!!!!!

Здравствуйте! Помогите пожалуйста, весь интернет облазила, не могу найти ответ на свой вопрос, вся надежда на этот сайт!

Задали сделать презентацию о Белке и Стрелке. Я работаю в "Презентация Microsoft PowerPoint" (в других не понимаю как, мне кажется эта наиболее удобная) и мне надо подобрать космический фон. Там, в "Дизайне" этой презентации ничего подобного нет. Я нашла в интернете подходящую картинку для фона, скачала ее на компьютер но я не знаю как ее вставить. Там есть "Шаблоны оформления на Microsoft Ofice Online", но там я ничего не поняла (написала "Космос", вышли несколько картинок, загрузила одну и теперь она неизвестно где) и есть "Шаблоны оформления: Дополнительные", там он просит найти фото. Я точно знаю куда я его загрузила. проверяю несколько раз, но он не находит. Помогите пожалуйста, 3 дня ответ не могу нигде найти!!!



Вы находитесь на странице вопроса "Помогите, пожалуйста, срочно написать код на паскале! Все голову сломала:(", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.