Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найдите количество элементов массива, которые больше заданного числа а, вводимого с клавиатуры

10-11 класс

Silach78787 03 июня 2016 г., 15:23:57 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Smolinakristin
03 июня 2016 г., 16:44:35 (7 лет назад)

program picaso; uses crt;
type vector=array[1..100] of integer;
var a:vector;
    i,n,k,p:byte;
begin clrscr; Randomize;
    writeln('n:');readln(n);
    writeln('a:');readln(p);
    for i:=1 to n do
    begin
        write('элемент ',i,' : ');
        readln(a[i]);
    end;
    for i:=1 to n do
        write(a[i],' ');
    k:=0;
    for i:=1 to n do
    begin
        if a[i] > p then inc(k);
    end;
    writeln('количество элементов массива, которые больше заданного числа',p,' : ',k);
end.

Ответить

Другие вопросы из категории

определите значение переменной а

а:=10
if a<5 then a:=a+12
else a:=a-7;
if a<5 then a:=a+12
else a:=a-7;

помогите решить парочку тестов. завтра зачет по информатике,а я что-то туплю. 1.В презентации можно использовать: a) оцифрованные фотограф

ии;

b) звуковое сопровождение;

c) документы, подготовленные в других программах;

d) все выше перечисленное

2.Вам нужно, чтобы смена слайдов происходила автоматически. Вы выберете в меню:

А. Показ слайдов/ смена слайдов

Б. Показ слайдов/ настройка анимации

В. Сервис/настройка

3. Можно ли цвет фона изменить для каждого слайд

А. Да

Б. Нет

В. Иногда

4.В рабочем окне программы PowerPoint, Impress нет элемента:

А. Область задач

Б. Область рабочего слайда

В. Строка заголовка

Г. Строка меню

д. Строка панель

Паскаль:

Найти кол-во двухзначных чисел, в записи которых встречается цифра 6

Читайте также

Задан одномерный массив размером 40. Определите количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного

числа 7 и меньше 10. Вывести количество элементов массива и среднее арифметическое значение этих элементов, которых больше заданного числа 7 и меньше 10 на монитор

срочно помогите решить! дам много пунктов!!! пожалуйста, зачет по информатике!! в qBasiq Вариант №

1

Дан массив целых чисел, состоящий из 20 элементов. Заполнить его с клавиатуры.

1. Найти:

- сумму элементов, имеющих нечетное значение;

- вывести индексы тех элементов, значения которых больше заданного числа А.

2. Определить, есть ли в данном массиве положительные элементы, кратные k (k вводить с клавиатуры).

Заполнить массив T размерностью M значениями, введенными с клавиатуры.

Вывести на экран в одну строку каждый 2 элемент массива, который больше заданного значения K. (Язык программирования - Паскаль)



Вы находитесь на странице вопроса "найдите количество элементов массива, которые больше заданного числа а, вводимого с клавиатуры", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.