Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан массив А(N) . Сформировать новый массив D(N) путем умножения отрицательных элементов массива A(N) на 25, а положительных на - 7. D новом массиве

10-11 класс

D(N) определить количество элементов, значение которых больше 100.

таткачка 05 мая 2015 г., 14:43:10 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
AnyaBuchkova
05 мая 2015 г., 16:59:33 (8 лет назад)

for i:=0 to N do
begin
if a{i] < 0 then
d[i]:=a[i]*25;
else
d[i]:=a[i]*7;
if abs(d[i]) > 100) then
inc(k);
end;

Вот кусок программы, вопросы задавай, если что.

+ 0 -
Красуля
05 мая 2015 г., 19:05:22 (8 лет назад)

const
N=5;
var
i,k: integer;
a,d: array [1..N] of integer;

begin
for i:=1 to N do
begin
write('a[',i,']= ');readln(a[i]);
end;
for i:=1 to N do
begin
if a[i] < 0 then
d[i]:=a[i]*25
else
d[i]:=a[i]*7;
if abs(d[i]) > 100 then
inc(k);
end;
write(k);
end.

Ответить

Другие вопросы из категории

Какой

объем памяти (в байтах) потребуется для хранения страницы русского текста из 10
строк по 50 символов в строке.

Читайте также

ПОЖАЛУЙСТА! НУЖНА ПОМОЩЬ!!!!

Дана матрица А (4, 5)
2, 3, -5, -10, 7
4, -10, -3, 2, 4
5, -2, -7, 11, -13
18, 19, -2, -4, -7
Из нее образовать две матрицы: в одной оставить все отрицательные элементы матрицы А (на месте положительных элементов поставить ноль), в другой оставить все положительные элементы (на месте отрицательных поставить ноль).
НАПИСАТЬ ПРОГРАММУ в VBA excel и скинуть сюда документом

ПОМОГИТЕ!!!!!

Дана матрица А (4, 5)
2, 3, -5, -10, 7
4, -10, -3, 2, 4
5, -2, -7, 11, -13
18, 19, -2, -4, -7
Из нее образовать две матрицы: в одной оставить все отрицательные элементы матрицы А (на месте положительных элементов поставить ноль), в другой оставить все положительные элементы (на месте отрицательных поставить ноль).
НАПИСАТЬ ПРОГРАММУ в VBA excel

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Дан массив А(N) . Сформировать новый массив D(N) путем умножения отрицательных элементов массива A(N) на 25, а положительных на - 7. D новом массиве", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.