Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дано вещественное число А и целое N (>0). Вывести все целые степени числа А от 1 до N.( решить задачу на языке С++)

10-11 класс

Rada230620031 16 июля 2013 г., 16:26:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fateeva7171
16 июля 2013 г., 18:59:15 (10 лет назад)

#include <iostream>
using namespace std;

int main(){
    int i,n; double a,p;
    cin>>n>>a; cout<<"\n";
    p=1;
    for(i=1; i<=n; i++) {p=p*a; cout<<i<<" "<<p<<"\n";}    
}

Тестовое решение:

5
1.8

1 1.8
2 3.24
3 5.832
4 10.4976
5 18.8957

--------------------------------
Process exited after 3.788 seconds with return value 0
Для продолжения нажмите любую клавишу . . .


Ответить

Другие вопросы из категории

помогите пожалуйста. нужно из 2-ичной системы счисления перевести в 10-ную.

1) 101.
2) 111.
3) 155.
4) 84.
пожалуйста.

Текст

объёмом 1024 бита располагается в оперативной памяти, начиная с
байта с номером 10. Каков будет адрес последнего байта, который
занят данным текстом?

Необходимо создать в чертежнике программу по формуле y=(x+1)+0.5 на интервале(-5;15)

шаг=1, значения вывести на экран. Мне необходимо написать это в письменном виде. Пример:
Использовать Чертежник
алг
нач
вещ.....

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа получает на вход

целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет
1)составьте программу вычисления суммы чисел в диапазоне от 45 до 115 45+....+115

2)Составьте программу которая выводит на экран числа кратные 2 и 13 в диапазоне от 2 до 150
3)Дано вещественное число А и целое число N(>0).Испульзуя один цикл вывести все целые степени числа А от 1 до N

------------------------ОПЕРАТОР WHILE

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.



Вы находитесь на странице вопроса "Дано вещественное число А и целое N (&gt;0). Вывести все целые степени числа А от 1 до N.( решить задачу на языке С++)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.