Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

дана матрица 5 на 5.надо создать такую программу которая будет выводить максимальное число каждой из строки.помогите плиз)

10-11 класс

DogSinger 30 нояб. 2013 г., 3:34:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Annarux
30 нояб. 2013 г., 4:56:02 (10 лет назад)

uses crt;
const n=5;
m=5;
var a:array[1..n,1..m] of integer;
i,j,max,t:integer;
begin
for i:=1 to n do
begin
for j:=1 to m do
read(a[i,j]);
end;
t:=1;
writeln;
repeat
max:=a[t,1];
for i:=t to t do
for j:=1 to m do
if a[i,j]>max then max:=a[i,j];
writeln(max);
inc(t);
until t>n
end.


+ 0 -
626234527
30 нояб. 2013 г., 7:47:26 (10 лет назад)

const
  n= 5;

var
  a: array [1..10,1..10] of integer;
  i,j,max: integer;

begin
  for i:= 1 to n do begin
    for j:= 1 to n do begin
      a[i,j]:= random(10);  // заполнение массива случайными числами
      write(a[i,j],' ')
    end;
    writeln
  end;
  for i:= 1 to n do begin
    max:= a[i,1];
    for j:= 1 to n do
      if a[i,j]>max then max:= a[i,j];
    writeln('максимум ',i,' строки',' =',max)
  end
end.

Ответить

Другие вопросы из категории

Даны действительные числа а, b, с. Удвоить эти числа, если а ≥ b

≥ с, и заменить их абсолютными
значениями, если это не так.

Решите пожалуйста, не понимаю(
дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые числа от о до 10000 включительно. Опишите на естественном языке или на

одном из языков программирования алгоритм, позволяющий найти и вывести максимальное значение среди трехзначных элементов массива, оканчивающихся на 0

Читайте также

Прошу вас помогите!Нужно написать программу,но только обязательно в Visual Basic!!!!!

На вход программе подаются сведения о
телефонах всех сотрудников некоторого учреждения. В первой строке
сообщается количество сотрудников N, каждая из следующих N строк имеет
следующий формат:

<Фамилия> <Инициалы> <телефон>

где <Фамилия> – строка, состоящая не более чем из 20 символов, <Инициалы> - строка, состоящая не более чем из 4-х символов (буква, точка, буква, точка), <телефон> – семизначный номер, 3-я и 4, я, а также 5-я и 6-я цифры которого разделены символом «–». <Фамилия> и <Инициалы>, а также <Инициалы <телефон> разделены одним пробелом. Пример входной строки:

Иванов П.С. 555-66-77

Сотрудники
одного подразделения имеют один и тот же номер телефона. Номера
телефонов в учреждении отличаются только двумя последними цифрами.
Требуется написать как можно более эффективную программу, которая будет
выводить на экран информацию, сколько в среднем сотрудников работает в
одном подразделении данного учреждения.


помогите коле и напишите программу или алгоритм которое находит все просые числа в диапазоне от m до N ВКлючительно

в задаче требуется написать программу которая по двум заданным числам находила бы в диапазоне между этими числами все простые числам где простое число которое имеет всего лишь два делителя то есть оно делится на единицу и на само себя и больше оно не на что не делиться например -3 7 11 помогите )) олимпиада по инфе )) даю максимум баллов ))

В некотором вузе абитуриенты проходили предварительное тестирование, по результатам которого они могут быть допущены к сдаче вступительных экзаменов в

первом потоке. Тестирование проводится по трём предметам, по каждому предмету абитуриент может набрать от 0 100 баллов. При этом к сдаче экзаменов в первом потоке допускаются абитуриенты, набравшие по результатам тестирования не менее 30 баллов по каждому из трёх предметов, причём сумма баллов должна быть не менее 140. На вход программы подаются сведения о результатах предварительного тестирования. Известно, что общее количество участников тестирования не превосходит 500. В первой строке вводится количество абитуриентов, принимавших участие в тестировании, N. Далее следуют N строк, имеющих следующий формат: <Фамилия> <Имя> <Баллы> Здесь <Фамилия> – строка, состоящая не более чем из 20 символов; <Имя> – строка, состоящая не более чем из 15 символов, <Баллы> – строка, содержащая два целых числа, разделенных пробелом – баллы, полученные на тестировании по каждому из трёх предметов. При этом <Фамилия> и <Имя>, <Имя> и <Баллы> разделены одним пробелом. Пример входной строки: Романов Вельямин 48 39 55 Напишите программу, которая будет выводить на экран фамилии и имена абитуриентов, допущенных к сдаче экзаменов в первом потоке. При этом фамилии должны выводиться в алфавитном порядке.



Вы находитесь на странице вопроса "дана матрица 5 на 5.надо создать такую программу которая будет выводить максимальное число каждой из строки.помогите плиз)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.