Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Напишите программу в Паскале, которая запрашивает у пользователя числа до тех пор, пока каждое следующее число больше предыдущего. В конце программа

10-11 класс

сообщает, сколько чисел было введено.

Dimanoid2 19 янв. 2015 г., 14:59:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
RAV777
19 янв. 2015 г., 15:48:41 (9 лет назад)

uses crt;
var a,t,ans:integer;
begin
read(a);
ans:=1;
while true do
begin
t:=a;
read(a);
if a>t then
ans:=ans+1
else
break;
end;
writeln(ans); 
end.

Ответить

Читайте также

Выбрать правильный ответ. Многократно повторяющаяся часть программы (алгоритма) называется: Циклом; Логическим условием; Оператором;

Ничего из вышеперечисленного.

Бесконечный цикл: Можно остановить путем ввода данных пользователем; Приводит к останову программы Можно использовать для создания короткой паузы в выполнении программы; Приводит к повторению некоторой части программы, пока не будет нажата клавиша “СТОП”.

Можно организовать цикл, повторяющийся до тех пор, пока не выполнится логическое условие с помощью операторов: FOR … NEXT IF… THEN GOTO Все вышеперечисленное.

Содержащаяся одна в другой циклические структуры называются: Вложенными; Простыми; Последовательными; Ничего из вышеперечисленного.

Какая из следующих строк может быть начальной строкой цикла FOR…NEXT: FOR A$=1 TO 15 FOR A=1 TO 15 FOR A=1 TO=15 FOR 4A=1 TO 15

Цикл FOR…NEXT приводит к повторению некоторой части программы, которая носит название: Тело цикла; Глубина цикла; Параметр цикла; Приращение.



Вы находитесь на странице вопроса "Напишите программу в Паскале, которая запрашивает у пользователя числа до тех пор, пока каждое следующее число больше предыдущего. В конце программа", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.