Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Составить программу, которая запрашивает числа и считает количество введенных отрицательных чисел, до тех пор, пока пользователь не введет 0.

10-11 класс

Использовать цикл с предусловием.
На обычном паскале, не турбо.

инштейниус 09 июня 2013 г., 3:44:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VLaDoZik
09 июня 2013 г., 4:58:59 (10 лет назад)

program z1;
var s:integer;a:double;
begin
        s:=0;a:=1;
        while a<>0 do begin
                readln(a);
                if a<0 then s:=s+1
        end;
        writeln(s);
        readln
end.

Ответить

Читайте также

Составить программу, которая вычисляет произведение сомножителей:

(1+1/1)(1+1/4)(1+1/9)(1+1/16)(1+1/25)(1+1/36)…
Вычисление происходит до тех пор, пока произведение сомножителей не станет больше, чем 3.6.
В ответе написать количество сомножителей для данного вычисления. В ответе указать только число, например, 15

Напишите прог-у на паскале... ПЛИИИИИИИИИИЗ 1)даны действительные числа a1, b1, c1, a2, b2, c2. Составьте программу, которая находит координаты точки

пересечения прямых, описываемых уравнениями a1x+b1x=c1 и a2x+b2x=c2. Если прямые пересекаются или не существуют-выдать соответствующее сообщение. 2) даны действительные числа a1, b1, a2, b2. Составьте программу, которая определяет, какая из точек A(a1;b1) или B(a2;b2) лежит на прямой у=2х+1. Если такой точки нет-вывести соответсвующее сообщение.



Вы находитесь на странице вопроса "Составить программу, которая запрашивает числа и считает количество введенных отрицательных чисел, до тех пор, пока пользователь не введет 0.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.