Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Паскаль. Дана последовательность чисел. Признак конца ввода - ноль. Определить сумму нечетных и оканчивающихся на 3, а также их кол-во.

5-9 класс

Piren96 18 янв. 2015 г., 21:31:34 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Anella86
19 янв. 2015 г., 0:25:08 (9 лет назад)

var
a,s,k:integer;
begin
k:=0;
s:=0;
repeat
readln(a);
if (a mod 2=1) then begin s:=s+a; k:=k+1; end;
until a=0;
writeln('Сумма нечетных и оканчивающихся на 3 = ',s);
writeln('Их количество = ',k);
end.

Ответить

Другие вопросы из категории

1. Галя, Марина и Оля пришли на праздничный утренник в платьях разного цвета: в желтом, синем и розовом. Галя была не в желтом, Марина – н

е в желтом и не в розовом. В каком платье была каждая девочка?

Задачка на смекалку))

Решенить задачу по паскаль

1.дано число х вычислите қол квадрат
2.имеется число а , число b в 2 раза больше, определить их сумму, числа целые. Срочно

Читайте также

Программа в Паскале! "Напишите программу, которая в последовательности целых чисел определяет сумму максимального и минимального чисел .

Программа получает на вход целые числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом ноль (ноль – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введенные числа по модулю не превышают 30000."

Отдал все пункты что есть! Помогите!

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

напишите программу, которая в последовательности натуральных чисел вычисляет сумму всех чисел кратных 7 и оканчивающихся на 0. Программа получает на

вход натуральные числа, количество введенных чисел неизвестно, последовательность чисел заканчивается числом 0 (0- признак окончания ввода, не входит в последовательность), Количество чисел не превышает 1000. Введенные числа не превышают 30000. Программа должна вывести одно число: сумму всех чисел, кратных 7 и оканчивающихся на 0. Программу надо написать в Pascal



Вы находитесь на странице вопроса "Паскаль. Дана последовательность чисел. Признак конца ввода - ноль. Определить сумму нечетных и оканчивающихся на 3, а также их кол-во.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.