Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите составить задание на языке Паскаль: Даны стороны прямоугольника: a и b. Найти: P-периметр, S-площадь, с-диагональ.

5-9 класс

Olikin 02 окт. 2014 г., 23:49:47 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ahmetshina
03 окт. 2014 г., 1:19:26 (9 лет назад)

Program Zn;
var a,b,S,P:integer;
c:real;
Begin
Writeln('Введите стороны а и b');
Readln(a);
Readln(b);
P:=2*a+2*b;
S:=a*b;
c:=sqrt(a*a+b*b);
writeln('P=',P);
Writeln('S=',S);
Writeln('c=',c);
end.

(Проверено и откомпилировано на Pascal.NET)

Ответить

Другие вопросы из категории

Помогите пожалуйста решить
ПОЖАЛУЙСТА, ПОМОГИТЕ, ПАСКАЛЬ, СРОЧНО!

1. Задать случайным образом 13 элементов числового массива – числа от 10 до 50. Удалить из него:
а) 10-ый элемент;
б) минимальный элемент.

2. Из символьного массива, 7 элементов которого заданы с клавиатуры, удалить максимальный элемент.

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Помогите составить программу на языке паскаль абц:

Вычислите площадь круга и длину окружности по исходным данным.



Вы находитесь на странице вопроса "Помогите составить задание на языке Паскаль: Даны стороны прямоугольника: a и b. Найти: P-периметр, S-площадь, с-диагональ.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.