Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

N учащихся получили оценки за контрольную работу. Ввести оценку каждого ученика, найти средний балл, количество отличных оценок.

5-9 класс

Программа на паскали

Aisel6 25 сент. 2015 г., 1:01:43 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Loveyou2010
25 сент. 2015 г., 2:00:42 (8 лет назад)

var 
  p:real;
  i,n,k,s:integer;
begin
 writeln('Введите количество учащихся');
 readln(n);
 k:=0;
 p:=0;
   for i:= 1 to n do 
      begin  
        read(s);
        if s=5 then k:=k+1;
        p:=p+s; 
     end;
 write('Средний балл ',p/n,' Количество отличных оценок ',k)
end.

Ответить

Другие вопросы из категории

дайте несколько возможных общих имён каждой группе

а) Буратино, Мальвина,Пьеро,Артемон.
б) "12 месяцев", "Морозко","Золушка", "Синяя борода".
в) Москва, Санк-Петербург, Новосибирск.
г) Енисей, Волга,Лена,Москва.
д) Москва, Санк-Петербург,Тула.

1 Действие компьютерного вируса состоит в том,что вместо букв "б" "в" "л" "о" "т" печатаются цифры,кроме цифры "о", причем разным буквам соответствует

разные цифры.Выясните,какие цифры каким буквам соответствуют,если известно,что

1) сумма цифр слова "бот" равна 8

2) сумма цифр слова "вол" равна 9

3) сумма цифр слова "ботл" равна 11

4) сумма цифр слова "лото" равна 12

2 Компьютерный вирус А заполняет 1 Гбайт за один месяц,вирус В заполняет 1 Гбайт за два месяца,вирус С заполняет 1Гбайт за три месяца,вирус В заполняет 1 Гбайт за шесть месяцев.На компьютере одновременно обнаружены сразу все четыре вируса.Сколько гигабайтов они заполнят за один месяц?

3 Предложите имена известных вам программ,открывающих файлы со следующими расширениями:

Расширение Программа

txt

doc

bmp

pdf

zip

сочинение на тему спорт

Читайте также

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 100 – баллы учащихся выпускного класса за итоговый

тест по информатике. Для получения положительной оценки за тест требовалось набрать не менее 20 баллов. Опишите на паскале алгоритм, который позволяет найти и вывести минимальный балл среди учащихся, получивших за тест положительную оценку.

В таблице Dat хранятся оценки (по десятибалльной шкале) студента по программированию за 8 прошедших с начала учебы семестров (Dat[1] -оценка за первый

семестр, Dat[2] - оценка за второй семестр и т.д.). Определите что будет напечатано в результате выполнения следующего алгоритма:

Var k,m, term: integer;

Dat: array[1..8] of integer;

begin

Dat[1]:= 7 ; Dat[2]:= 7 ; Dat[3]:=6 ; Dat[4]:= 8 ;

Dat[5]:=4 ; Dat[6]:= 5; Dat[7]:= 4; Dat[8]:= 7;

term:=1; m:=Dat[1];

for k:=2 to 8 do

begin if Dat[k] < m then

begin m:=Dat[k]; term:=k

end end

write (term); end.

Определите средний балл всех решить на С#Определите средний балл всех учащихся по каждому предмету.

Формат входных данных Заданы сначала количество учащихся n, затем n строк, каждая из которых содержит фамилию, имя и три числа (оценки по трем предметам: математике, физике, информатике). Данные в строке разделены одним пробелом. Оценки принимают значение от 1 до 5.
Формат выходных данных Выведите три действительных числа: средний балл всех учащихся по математике, по физике, по информатике.Пример
Ввод Вывод
4 4.75 3.75 4.5
Ivanov Vasiliy 5 3 4
Petrov Sergey 4 3 5
Konstantinov Nikolay 5 5 5
Kuznetsov Ivan 5 4 4



Вы находитесь на странице вопроса "N учащихся получили оценки за контрольную работу. Ввести оценку каждого ученика, найти средний балл, количество отличных оценок.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.