Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Сделайте обработку массива для i от 6 до 10. For i:= 0 to 10 do A [Сделайте обработку массива для i от 6 до 10.

10-11 класс

For i:= 0 to 10 do
A [ i] := i ;
for i := 0 to 10 do
begin
k := A [i];
A [i] : = A[10-i];
k := A[10-i];end;
У меня получилось 10 9 8 7 6 5 4 3 2 1 0 (но после 5 не правильно) решите с объяснением!

Milana5020 15 нояб. 2016 г., 6:54:28 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ale4ka13
15 нояб. 2016 г., 9:29:42 (7 лет назад)

Var a:array[1..10] of integer;
i:integer;
Begin
 for i:=1 to 10 do
   a[i]:=i;
 for i:=6 to 10 do
   {Здесь пишется то, что нужно сделать с массивом. Например, нам нужно просто вывести эти элементы, тогда:}
   {write(a[i],' ');}
End.

+ 0 -
375291735359
15 нояб. 2016 г., 12:26:31 (7 лет назад)

Я не совсем понял, что требуется. Нужно что-то сделать с элементами массива, индекс которых лежит в промежутке [6;10]? Если да, то что с ними нужно сделать, как именно обработать? Как вводить массив - в нем могут содержаться любые элементы, или только числа от 1 до 10 по порядку?

+ 0 -
Tancik31
15 нояб. 2016 г., 13:16:23 (7 лет назад)

Нужно что-то сделать с элементами массива, индекс которых лежит в промежутке [6;10] - да,их нужно обработать, числа должны быть только от 0 до 10.например Нужно подставлять i(индекс)=0 в ячейке с индексом 0 будет число 10.

Ответить

Другие вопросы из категории

Паскаль. Дана действительная матрица размера n×m, в

которой есть хотя бы один ненулевой элемент. Получите новую матрицу путем
деления всех элементов заданной на ее наибольший по абсолютной величине элемент

пожалуйста,помогите решить уравнение

M+9L-K-2T+p
M=33257(10)
L=97A(16)
T=76705(8)
p=FBO1(16)
K=1 0000 0000 0011 0101(2)


помогите запрограммировать в Турбо Паскале))

задание на картинке)
Зарание спасибо)

Читайте также

Сделайте обработку массива для i от 6 до 10. For i:= 0 to 10 do A [ i] := i ; for i := 0 to 10 do begin k := A

[i];

A [i] : = A[10-i];

k := A[10-i];

end;

В программе используется одномерный целочисленный массив А с индексами от 0 до 10. Ниже представлен фрагмент программы в котором значения элементов

сначала задаются,а затем меняются.

Нц для i от 0 до 10

А [ i ] := i

кц

Нц для i от 0 до 4

С := A[ i ]

A[ i ] := A [10 - i ]

A [10 - i ] :=C

кц

Чему будут равны элементы массива после выполнения фрагмента программы?

1) 10 9 8 7 6 5 4 3 2 1 0

2) 0 1 2 3 4 5 6 7 8 9 10

3) 10 9 8 7 6 5 6 7 8 9 10

4) 0 1 2 3 4 5 4 3 2 1 0

Определите значение целочисленной переменной S после выполнения операторов: нц для i от 1

до 3 S:=0 нц для j от 2 до 3 S:=S+i+j кц кц
ПОМОГИТЕ

№1 Вывести на экран квадраты чисел от 1 до n. №2 Вывести на экран таблицу умножения от 1 до 10

числа n.

№3

Вычислить значение факториала n!

№4

В диапазоне от 1 до n вывести все четные числа на экран.

№5

Найти количество чисел, которые делятся на 3 и 5, из диапазона от 1 до n.

Для кодирования номеров автомобилей принята следующая структура данных: Номер региона (двузначное число от 00 до 99), серия (комбинация из трех букв из

набора «А, В, Е, К, М, Н, О, Р, С, Т, У, Х»), номер (трехзначное число от 000 до 999). При создании базы данных автомобильных номеров Петя решил хранить каждый номер в виде массива из 8 символов (два символа на номер региона, три символа на серию и три символа на номер), кодируя каждый символ с помощью однобайтной кодировки ASCII. Вася решил уменьшить объем хранимых данных и принял решение хранить каждый номер в виде трех чисел – одно число для номера региона, одно число для серии (представив все возможные серии в виде натуральных чисел) и одно число для номера. Каждое число Вася будет хранить отдельно, используя для его кодирования минимально возможное число бит. На сколько бит уменьшится объем памяти, необходимый для хранения одного произвольного номера, в варианте кодирования Васи по сравнению с вариантом кодирования Пети? В ответе укажите целое число.



Вы находитесь на странице вопроса "Сделайте обработку массива для i от 6 до 10. For i:= 0 to 10 do A [Сделайте обработку массива для i от 6 до 10.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.