Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Оценки школьника за четверть заданы в виде строки символов.подсчитать средний балл школьника. помогите пожалуйста, контрольная!

10-11 класс

Guw4uk1 01 нояб. 2013 г., 6:06:20 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
пшдг
01 нояб. 2013 г., 8:11:18 (10 лет назад)

uses crt;
var c:char;  
  n:integer;    
 sr:real;
begin
writeln('Введите в строку оцеки от 2 до 5 без пробелов, оеончание ввода Enter'); sr:=0;
n:=0;
repeat c:=readkey;
if c in ['2'..'5'] then
  begin   write(c);  
 n:=n+1;  
sr:=sr+ord(c)-48;
 end;
if c=#13 then writeln;
until c=#13;
sr:=sr/n;
write('Средняя оценка=',sr:0:1)
end.


Ответить

Другие вопросы из категории

1) Два игрока, Петя и Ваня, играют в следующую игру. Перед игроками лежит куча камней. Игроки ходят по очереди, первый ход делает Петя. За один ход игро

к может добавить в кучу два камня или увеличить количество камней в куче в два раза. Например, имея кучу из 15 камней, за один ход можно получить кучу из 17 или 30 камней. У каждого игрока, чтобы делать ходы, есть неограниченное количество камней. Игра завершается в тот момент, когда количество камней в куче становится не менее 25. Победителем считается игрок, сделавший последний ход, то есть первым получивший кучу, в которой будет 25 или больше камней.
В начальный момент в куче было S камней, 1 ≤ S ≤ 24.
1. При каких S: 1а) Петя выигрывает первым ходом; 1б) Ваня выигрывает первым ходом?
2. Назовите три значения S, при которых Петя может выиграть своим вторым ходом?
3. При каком S Ваня выигрывает своим первым или вторым ходом?

Переведите следующее число в десятичную систему счисления:

а) 57.
Как это сделать?

Читайте также

1)Какое количество информации несёт сообщние о том, что встреча назначена на 9:00? 2) За четверть ученик получил 100 оценок. Сообщение о том,

что он получил тройку несёт 3 бита информации. Сколько троек получил ученик за четверть?

За четверть ученик получил 100 оценок. Сообщение о том, что он получил пятёрку,

несёт 2 бита информации. Сколько пятёрок ученик получил за четверть?
(распишите пожалуйста по действиям с формулой N=2^i)

Составить программы: 1.Дана строка символов, среди которых есть двоеточие. Определить, сколько символов следуют за двоеточием.

2.Дана строка символов, среди которых есть одна открывающаяся и одна закрывающаяся скобка. Подсчитать, сколько слов расположено внутри этих скобок.

3.Дана строка. Удалить из нее все запятые и подсчитать, сколько получилось удаленных символов.

Помогите, пожалуйста!

помогите плз! 3) Шахматная доска состоит 8 столбцов и 8 строк. Какое минимальное количество бит потребуется для кодирования координат одного

шахматного поля?

4) Какое минимальное количество бит потребуется для кодирования положительных чисел, меньших 60?

5) Двое играют в «крестики-нолики» на поле 4 на 4 клетки. Какое количество информации (в битах) получил второй игрок, узнав ход первого игрока?

6) В корзине лежат 8 черных шаров и 24 белых. Сколько бит информации несет сообщение о том, что достали черный шар?

7) В коробке лежат 64 цветных карандаша. Сообщение о том, что достали белый карандаш, несет 4 бита информации. Сколько белых карандашей было в коробке?

8) За четверть Василий Пупкин получил 20 оценок. Сообщение о том, что он вчера получил четверку, несет 2 бита информации. Сколько четверок получил Василий за четверть?

9) В корзине лежат черные и белые шары. Среди них 18 черных шаров. Сообщение о том, что достали белый шар, несет 2 бита информации. Сколько всего шаров в корзине?

10) В закрытом ящике находится 32 карандаша, некоторые из них синего цвета. Наугад вынимается один карандаш. Сообщение «этот карандаш – НЕ синий» несёт 4 бита информации. Сколько синих карандашей в ящике?

Как составить программу автоматического переноса слов? задается максимальная длина строки и предполагается, что слова разделяются пробелом. В этом

случае надо следить за текущей позицией в строке и при вводе очередного "слова" контролировать, чтобы его длина плюс текущая позиция не превысили длины строки. в QBasic



Вы находитесь на странице вопроса "Оценки школьника за четверть заданы в виде строки символов.подсчитать средний балл школьника. помогите пожалуйста, контрольная!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.