Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

пожалуйста,помогите написать программу,на языке С++,которая считает сумму цифр числа,которое содержит не больше шести разрядов.

10-11 класс

Lychevaarina 11 дек. 2014 г., 6:22:17 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dasddfsh
11 дек. 2014 г., 8:43:41 (9 лет назад)

#include <iostream>
using namespace std;

int main()
{
  int n,sum = 0;
  cout <<"N = ";
  cin >>n;
  while (n!=0)
  {
    sum+=n%10;
    n/=10;
  }
  cout <<"Summa: " <<sum <<'\n';
  return 0;
}

Ответить

Другие вопросы из категории

Исполнитель кузнечик живёт на числовой оси. Кузнечик умеет выполнять команды: "вперёд N" (кузнечик прыгает вперёд на N единиц), назад М (кузнечик

прыгает назад на М единиц). Передвижения N и М могут принимать любые целые положительные значения. Известно, что кузнечик (?выполняя?) программу из 70 команд, в которой команд "назад 2" на 20 больше, чем команд "вперёд 3". Других команд в программе не было. На какую одну команду можно заменить эту программу, чтобы кузнечик оказался в той же точке, что и после выполнения программы.

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

1) Напишите пожалуйста программу (на языке BASIC) вычисления по длинам двух сторон треугольника и углу между ними длины третьей стороны и двух других

углов.
2)
Напишите пожалуйста программу (на языке BASIC) для определения подобия:
а) двух прямоугольников по двум смежным сторонам;
б) двух треугольников по трем сторонам.

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму



Вы находитесь на странице вопроса "пожалуйста,помогите написать программу,на языке С++,которая считает сумму цифр числа,которое содержит не больше шести разрядов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.