Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу на паскале в которой введенное предложение будет разделяться на отдельные слова. Вводи A. разделяем предложения на слова присваивая

5-9 класс

их к какой либо переменной

Natali1197710 25 янв. 2015 г., 21:59:10 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ttanusha
25 янв. 2015 г., 22:41:55 (9 лет назад)

const
pat = ':, .!?';
var
p : string;
a : array [1..100] of string;
c, i : integer;
begin
readln(p); //предложение
a[c + 1] := '';
for i := 1 to length(p) do
begin
if pos(p[i], pat) = 0 then
a[c + 1] := a[c + 1] + p[i]
else
begin
if length(a[c + 1])>0 then inc (c);
a[c + 1] := '';
end;
end;
for i := 1 to c do
begin
writeln (a[i]);
end;
readln;
end.

Ответить

Другие вопросы из категории

Помогите составить программу на языке паскаль абц:

Вычислите площадь круга и длину окружности по исходным данным.

Народ,помогите пожалуйста.

Я ,конечно,знаю,что не совсем по теме,но если вы знаете информатику,то помогите)
Где можно скачать:Support\Updates...(это обновление на игру симсов)

что такое чип сет, урок информатики

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Ребят) Помогите с программой на Паскале, пожалуйстаа)

Нужно написать программу, которая выводит на экран все двухзначные числа, делящиеся на 3 или на 5 (использовать операции целочисленного деления div или mod)

Пожалуйста помогите создать какую нибудь полезную программу на паскаль , срочно нужно до понедельника, чтобы в этой программе были все темы за 8 класс,

read.writeln.else.to.if и тд которые сможете
Вот пример идеи для программы, в академию поступают какое то количество учеников, нужно написать сколько учеников сдали документы, сколько пришли на экзамен, и сколько учеников кто прошло и не прошло
возможно не возможно создать программу на этой идее, тогда прделагайте свои со своими программами , пожалуйста помогите!



Вы находитесь на странице вопроса "Написать программу на паскале в которой введенное предложение будет разделяться на отдельные слова. Вводи A. разделяем предложения на слова присваивая", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.