Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее

10-11 класс

количество осадков за этот год, среднемесячное количество осадков, количество засушливых месяцев (когда количество осадков было меньше 30 мм), самый засушливый месяц года. для Turbo Pascal.

Smirnov191197 08 нояб. 2015 г., 6:33:57 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
ELITENICK
08 нояб. 2015 г., 8:39:08 (8 лет назад)

program zadacha;
var
a: array [1..12] of integer;
i, o, k, z, j: integer;
s:real;
begin
writeln('vvedite kolichestvo osadkov');
for I:=1 to 12 do
read(a[I]);
o:=0;
for I:=1 to 12 do
o:=o+a[I];
writeln('obshee kolichestvo osadkov=',o);
s:=o/12;
writeln('srednee kolichestvo=',s:3:2);
k:=0;
for i:=1 to 12 do
if a[I]<30 then k:=k+1;
writeln('kolichestvo zasushlivih=',k);
j:=30;
for I:=1 to 12 do
if a[I] begin
j:=[I];
z:=I;
end;
writeln('samiy zasusliviy mesyac=',z);
readln;
end.

Ответить

Другие вопросы из категории

1)Три десятичных числа(100,102,91) перевести в восьмеричную систему вычислить их сумму и перевести в десятичную систему вычислить их сумму и перевести в

десятичную.
2)Три двоичных числа перевести в 16-ую систему,вычислить их сумму и перевести в десятичную систему.
3)Три двоичных числа,перевести в 8-ую систему,а затем в 16-ую.
Просьба написать всё ясно и понятно!!!!!!!Потому что я совсем не разбираюсь!

Читайте также

1. Дан массив. Напечатать:

а) Все четные элементы
б) Все элементы, оканчивающиеся нулем.

2. В массиве хранится информация о количестве осадков, выпавших каждый день января. Определить, в какие числа месяца осадков не было.

1. Дан массив. Напечатать:а) Все четные1. Дан массив. Напечатать:

а) Все четные элементы
б) Все элементы, оканчивающиеся нулем.

2. В массиве хранится информация о количестве осадков, выпавших каждый день января. Определить, в какие числа месяца осадков не было.

Паскаль.

помогите исправить ошибки.Масиви. Уплотнить линейный массив, удалив нули и сдвинув влево остальные элементы program

{ Уплотнить линейный массив удалив нули и сдвинув влево остальные элм.}

uses crt

var m,i,k:longint a:array[1..100]of longint

begin

clrscr

write('введите кол-во элм таблицы: ')redln(k)

for i=1 to k do

begin

write('a[',i,']=')redln(a[i])

end

m=0

for i=1 to k do

if a[i]=0 then inc(m)

elsey a[i-m]=a[i]k=k-m

for i=1 to k do write(a[i],' ')redln

end.

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .



Вы находитесь на странице вопроса "Линейный массив содержит сведения о количестве осадков, выпавших за каждый из 12 месяцев одного года. Составить программу, определяющую общее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.