Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Найдите ошибку в 7 строке(Qbasic) :

10-11 класс

CLS
K = 0
DIM B(K)
INPUT N
FOR I = 1 TO N
INPUT A
IF A > 0 AND A MOD 3 = 0 THEN K=K+1 : B(K) = A
NEXT I
IF K > 0 THEN GOTO 10 ELSE GOTO 20
C = K
10 FOR D = C TO 1
PRINT B(K)
NEXT D
END
20 PRINT -1
END

Minisa 02 апр. 2017 г., 5:12:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katerina5555
02 апр. 2017 г., 6:50:05 (7 лет назад)

CLS
K = 0
DIM B(10000)
INPUT N
FOR i = 1 TO N
INPUT A
IF A > 0 AND (A MOD 3) = 0 THEN K = K + 1: B(K) = A
NEXT i
IF K > 0 THEN GOTO 10 ELSE GOTO 20
10 :
C = K
FOR D = C TO 1 STEP -1
PRINT B(D)
NEXT D
END
20 :
PRINT -1
END

Ответить

Другие вопросы из категории

Дано натуральное трехзначное число M. Определить сумму и

произведение его цифр.

Составить программу:

сформировать в памяти массив из 15 целых чисел.Изменить массив так,чтобы числа под чётными номерами были удвоены,а на нечётных-заменены нулями.
Пожалуйста!

Читайте также

1. Запишите следующее выражение по правилам программирования:



2. Выпишите недопустимые имена переменных:

a) Nomer;
b) S34;
c) И92;
d) Kol_vo54;
e) 45_A;
i) fg-л23

3. Установите соответствие (с помощью стрелок) между переменной и типом данных:

а) A:=3.234 а) Integer
b) Z:=14 b) Real
c) B:=10351 c) Byte
d) K:=-0.2 d) Word
e) C:= 64000

4. Запишите инструкцию:

а) присваивающую переменной V значение 7;

б) увеличивающую значение переменной Z на 30;

в) вычисляющую значение переменной R по формуле (X2+Y2):2;

5. Опишите переменные, необходимые для вычисления:


при x=-5.3, y=7.42

6. Напишите инструкцию вывода на экран:
а) вашего имени б) числа 400 в) значения выражения 7,3(3,22+8,61)

7. Определите, какое значение примет переменная С в результате выполнения данной последовательности операторов присваивания:

a:=8; b:=a/2; c:=43 mod a; a:=(b+c) div 6; b:=b+1; c:=sqrt(abs(a*b-14));

8. Установите соответствие между служебными словами и названиями разделов программы:

а) Var а) Раздел операторов
b) Program b) Раздел имени программы
c) Uses c) Раздел описания переменных
d) Begin …end d) Раздел описания библиотечных модулей

9. Найдите ошибки в записях оператора:

a) Write ©;
b) Writeln;
c) Writeln (Введите любое число);
d) Write X,Y;
e) WRITELN (‘воскресенье, нерабочий день’);

10. Какая структура программы верная:

begin
program MyFirst;
X:=Y+195;
end.


program MyProg;
begin
Writeln (‘Привет’);
end.

11. Расположите в правильном порядке строки программы, вычисляющей периметр и площадь параллелограмма:

1) S:=a*h;

6) var a,b,h,p,s: integer;

2) end.

7) readln;

3) program pr;

8) Writeln(‘p=’,p,’ s=’,s);

4) p:=2*(a+b);

9) a:=6;b:=3;h:=4;

5) Uses crt;

10) clrscr;

11) begin

12. Дан текст программы в таблице с ошибками:

исправьте ошибки в программе;что выведется на экран в результате выполнения программы?

Программа с ошибками

Программа без ошибок

На экране будет напечатано:

War: a,b,c – integer, x: real;
Bigin
A=7, b=3,2, c:=a+b;
Writln (summa=, c);
C:=c/2; x:=a-c;
Writeln(‘x=’ , x, ‘kvadrat=’, x*x);
and

13. Перевести блок-схему на язык Паскаль.

Вычисление расстояния между точками А и B.



30 пунктов!!!Паскль.найдите ошибку и объясните, пожалуйста!!умоляю, ребят!

Подсказка: ошибка связана с "writeln"

Найдите ошибку,ибо выдает он всегда,что спортсмен не проходит,даже если сумма 100,а общее количество 60.!!!

В массиве хранится информация о баллах,
полученных спортсменом-десятиборцем в каждом из десяти видов спорта. Для выхода
в следующий этап соревнований общая сумма баллов должна превысить некоторое
известное значение. Определить вышел ли данный спортсмен в следующий этап
соревнований.

1)Найдите ошибки в программах:

a) Program Ошибки1;
Begin
Summa:=6+8;
End;
b) Program Ошибки2;
Begin
Var X:integer;
X:=6+8;
Write(X);
End;




2)Даны два числа. Найти среднее арифметическое кубов этих чисел и среднее геометрическое модулей этих чисел.
ДАННУЮ ПРОГРАММУ НУЖНО НАПИСАТЬ В ПАСКАЛЕ.

Ошибка времени выполнения: Входная строка имела неверный формат

Написал программу:

var
f1,f2:text;
d,s,z,n:longword;
a,b,t,m,x:smallint;
begin
assign(f1,'input.txt');
reset(f1);
assign(f2,'output.txt');
rewrite(f2);
readln(f1,d,a,b,s,t);
if a>b then x:=a-b else x:=b-a;
if d mod s=0 then n:=d div s else n:=d div s+1;
if x mod t=0 then m:=x div t else m:=x div t+1;
z:=n+m;
write(f2,z);
close(f1);
close(f2);
end.

Выдает ошибку: Ошибка времени выполнения: Входная строка имела неверный формат.
Где выдает ошибку: readln(f1,d,a,b,s,t);

ПОМОГИТЕ пожалуйста!!!



Вы находитесь на странице вопроса "Найдите ошибку в 7 строке(Qbasic) :", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.