Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Процедуры и функции. паскаль Даны 2 одномерных массива 10 целых чисел. Найти сумму квадратов всех элементов массива для ко

10-11 класс

торых выполняется неравенство 0<x<10

Cherkashnev08 19 нояб. 2016 г., 4:03:15 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Skripchenko1998
19 нояб. 2016 г., 6:59:52 (7 лет назад)

program a;

var i,n :integer;

a,b,c :array [1..10] of integer;

 

begin

for i:=1 to n do begin

readln(a[i],b[i]);

end;

 

for i:=1 to 10 do begin

if (a[i]>0) and (a[i]<10) then

if (b[i]>0) and (b[i]<10) then

c[i]:=a[i]*a[i]+b[i]*[b];

endif;

endif;

end;

 

for i:=1 to n do begin

writeln('C[',i,']=',c[i]);

end;

end.

Ответить

Другие вопросы из категории

Читайте также

Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом

массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве. Результаты сохранить в одномерном массиве и элементы массива отсортировать по возрастанию

Помогите составить блок-схему алгоритма и программу на алгоритмическом языке программирования БЕЙСИК обработки одномерного массива.Заполнение массива

элементами организовать путем ввода с клавиатуры.В одномерном массиве из N чисел вывести на экран отрицательные элементы и сообщите об их количестве.Пожалуйста,срочно надо.

№1 Дана действительная квадратная матрица порядка n. Найти произведение четных элементов.

№2 В данном одномерном массиве Х[1..n] найти сумму отрицательных элементов , кратных 7.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.



Вы находитесь на странице вопроса "Процедуры и функции. паскаль Даны 2 одномерных массива 10 целых чисел. Найти сумму квадратов всех элементов массива для ко", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.