Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

с клавиатуры вводится целое число N,найти произведение всех цифр этого числа,а также количество цифр больше 6

5-9 класс

ЭлизабетСмит 29 окт. 2013 г., 15:47:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maxanddimon
29 окт. 2013 г., 17:20:09 (10 лет назад)

uses crt;
var n,a,k,s:integer;
begin
readln(n);
a:=n;
repeat;
a:=n mod 10;
s:=s+a;
n:=n div 10;
if a>6 then inc(k);
until a=0;
writeln(s);
writeln(k);
end.

Ответить

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

Помогите))С клавиатуры вводится целое 4-х значное число.

Выдать сообщение о том, есть ли в этом числе четные цифры и указать их
количество.
НА ПАСКАЛЕ



Вы находитесь на странице вопроса "с клавиатуры вводится целое число N,найти произведение всех цифр этого числа,а также количество цифр больше 6", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.