Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Помогите решить)

10-11 класс

Ввести массив a1,a2,a3..a20.Элементы, на чётных местах, расположить в порядке возрастания , а на нечётных в порядке убывания. У этого сайта нет рейтинга

Dashahandball 15 февр. 2014 г., 7:14:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Keanag
15 февр. 2014 г., 8:59:19 (10 лет назад)

var
  i,j,p:integer;
  a:array[1..20]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 20 do
  begin
  a[i]:=random(20);
  write(a[i],' ');
  end;
writeln;
i:=1;
while i<21 do
  begin
  j:=i;
  while j<21 do
    begin
    if a[i]<a[j] then
      begin
      p:=a[i];
      a[i]:=a[j];
      a[j]:=p;
      end;
    j:=j+2;
    end;
  i:=i+2;
  end;
i:=2;
while i<21 do
  begin
  j:=i;
  while j<21 do
    begin
    if a[i]>a[j] then
      begin
      p:=a[i];
      a[i]:=a[j];
      a[j]:=p;
      end;
    j:=j+2;
    end;
  i:=i+2;
  end;
writeln('Измененный массив:');
for i:=1 to 20 do write(a[i],' ')
end.

Ответить

Другие вопросы из категории

Информатика очень срочно
Электронный почтовый ящик имеет объем 1,535 Мбайт. Информация на его адрес по открытому на прием каналу связи передается со скоростью 2,5 Кбайт / с.

Через какое время у поставщика услуг электронной почты появится повод прислать извещение о переполнении почтового ящика? Укажите время в секундах

P.S. Напишите очень разборчиво в переводе едениц

Иван, Петр и Сергей-три друга.В их семьях ожидается прибавление,причем первым должен стать отцом Иван,за ним Сергей и последним-Петр. Будущие отцы

обратились к астрологам с просьбой открыть им, кто у них родится-сын или дочь.Пять астрологов дали следующие предсказания:
А.Хотя бы у одного из вас будет сын.
В.Хотя бы у одного из вас будет дочь.
С.Только у одного из вас родится дочь.
D.Пол первого родившегося ребенка будет отличаться от пола двух остальных детей .
E. Или у всех родятся сыновья, или у всех родятся дочери.
Запутавшиеся в предсказаниях друзья обратились к астрологу-математику,который сказал им. что ошибся только один астролог.Определите,кто у кого родился и какой астролог ошибся.

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22

Помогите решить две задачки (Паскаль)

Задание 1
В одномерном массиве случайных вещественных числе F(17) определить количество положительных элементов и их сумму.

Задание 2
В матрице L(5,5) случайных вещественных чисел определить максимальный элемент выше побочной диагонали, поменять его местами с элементом 2 строки 2 столбца.

Большая просьба расписать задачу подробно , хочу не просто списать решения , а понять его и научиться решать сам , огромное спасибо.

Здравствуйте, прошу помогите решить такое вот чудо.

Решить вроде бы нужно найти что за число вместо x.
Кто знает как правильнее прошу вашей помощи.
Чтобы просмотреть фото, кликните на него.



Вы находитесь на странице вопроса "Помогите решить)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.