Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

User вводит расстояние до цели (число). затем производит серию выстрелов - 10 чисел. программа выводит: попал...недолет...перелет

5-9 класс

BoBuk2 27 июля 2014 г., 5:03:20 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ivanharitonov
27 июля 2014 г., 7:54:57 (9 лет назад)

Program Task;
Const count = 10;
Var shoots: Array [1..count] of Integer;
    distance, i: Integer;
Begin
    WriteLn('Введите расстояние до цели');
    ReadLn(distance);
    WriteLn('Введите серию выстрелов');
    For i := 1 To count Do
        Read(shoots[i]);
    WriteLn('Результат:');
    For i := 1 To count Do
        If shoots[i] < (distance - 5) Then
                    WriteLn(i, '. Недолет')
        Else If shoots[i] > (distance + 5) Then
            WriteLn(i, '. Перелет')
        Else
            WriteLn(i, '. Попал');
    ReadLn;
End.

+ 0 -
10Лилия10
27 июля 2014 г., 9:13:23 (9 лет назад)

uses crt;
const 
  h=10;
var 
  a: array [1..h] of integer; 
  x,n: integer;  
begin 
  write('Расстояние до цели= '); readln(n); 
  for x:=1 to h do 
    a[x]:=random(n*2); 
  for x:=1 to h do 
  begin   
    write('Дальность выстрела ',a[x]); 
    if a[x]=n then writeln(' - Попал'); 
    if a[x]>n then writeln(' - Перелёт');
    if a[x]<n then writeln(' - Недолёт'); 
 end;
end.

+ 0 -
Alesafronov07
27 июля 2014 г., 11:21:31 (9 лет назад)

затем производит серию выстрелов - 10 чисел.
Можно поподробнее? Что за числа?

+ 0 -
FruKTikGraf
27 июля 2014 г., 14:15:28 (9 лет назад)

абсолютно любые числа. расстояние должно быть конкретно 10. то есть от 1 до 10, от 440 до 449. вообще условие дано такое и никаких пояснений больше нету

+ 0 -
Lisa1982
27 июля 2014 г., 15:03:54 (9 лет назад)

Сделаем)

+ 0 -
Eduardchepukasвика
27 июля 2014 г., 17:38:50 (9 лет назад)

давайте) буду очень благодарна

+ 0 -
Rama1993
27 июля 2014 г., 19:53:03 (9 лет назад)

Выстрелы нужно вводить или случайно генерировать?

Ответить

Другие вопросы из категории

Читайте также

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

1)Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все

элементы с четными значениями на 1. Если элементы с чётными значениями отсутствуют, оставить массив без изменений.

2) Составте программуб которая заполняет массив а[1..10] случайными целыми числами в диапозоне от 1 до 10,затем преобразовывает его,увеличивая все элементы с нечётными значениями в три раза,а элементы с чётными значениями заменяя на 0.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.
5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева
б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.
6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.
б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.
напишите хоть какое нибудь нужно к завтрому срочно

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве



Вы находитесь на странице вопроса "User вводит расстояние до цели (число). затем производит серию выстрелов - 10 чисел. программа выводит: попал...недолет...перелет", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.