Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Pascal ! Срочно!

5-9 класс

Дан массив из 10 целых чисел. Найти количество положительных элементов, кратных 3-м.

MaksimkaNaimushin 09 июля 2014 г., 22:17:02 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Baranan12
10 июля 2014 г., 0:32:41 (9 лет назад)

const n=10;
var a:array[1..n] of integer;
i,k:integer;
begin
for i:=1 to n do a[i]:=random(50)-20;
for i:=1 to n do write(a[i]:4);
writeln;
k:=0;
for i:=1 to n do
if (a[i]>0) and (a[i] mod 3 = 0) then k:=k+1;
write('количество положительных элементов, которые кратны 3 = ',k);
end.

Ответить

Другие вопросы из категории

ЗАДАЧА

Крестьянин пришел к царю и поппросил:《Царь, позволь мне взятьиз твоего сада одно яблоко》. Царь сказал 《Мой сад огорожен тремя заборами. В каждом заборе есть только одни ворота и около каждых ворот стоит сторож. Если скажешь сколько яблок тебе нужно взять, чтобы выполнить следующие условия - разрешу взять яблоко.
Первому сторожу отдай половину яблок, которые возьмешь и ещё одно яблоко. Второму сторожу отдай половину оставшихся яблоко и ещё одно яблоко. Третьему стопожу отдай половину из того что осталось и ещё одно яблоко, а тебе, чтобы осталось одно яблоко.》Крестьянин подумал и ответил царю. Царь разрешил пойти в сад. Какое число назвал крестьянин царю?

Читайте также

Очень срочно. даю 100 пунктов. Pascal ABC. Если не сдам, будет 3 за четверть(((((((((((((( Написать программу, которая

сортирует массив ПО УБЫВАНИЮ и ищет в нем элемент, равный X (это число вводится с клавиатуры). Использовать двоичный поиск.

Срочно нужна сказка об информатике и

человеке! Буду благодарна! 6 класс Уже 4 раз пишу:с На завтра срочно нужно,не знаю что писать :ссс

Срочно! Напишите сообщение про Системный блок. Рзамером, примерно с альбомный лист.

Только содердательно и понятным языком. Срочно, пожалуйста помогите!

:)

Помогите пожалуйста, срочно надо Составь программу на Pascal для этой задачи:

С кондитерской фабрики отгружают конфеты в коробках по 10 кг, 5 кг и 1 кг. Какое наименьшее количество коробок потребуется для перевозки N килограмм конфет?



Вы находитесь на странице вопроса "Pascal ! Срочно!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.