Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу для решения следующей задачи: Дана последовательность символов,концом которой является точка.Подсчитать,сколько в этой

5-9 класс

последовательности букв а. Pascal.Срочно плиз помогите!!!

Diana664 11 июля 2014 г., 14:27:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fknjsdfkv
11 июля 2014 г., 16:19:19 (9 лет назад)

program test;
var k,i:integer;s:string;
begin
readln(s);
for i:=1 to (length(s)-1) do // -1 это точка
if s[i]='a' then k:=k+1;
writeln(k);
end.

Ответить

Другие вопросы из категории

У Васи есть доступ к Интернет по высокоскоростному одностороннему

радиоканалу, обеспечивающему скорость получения им информации 2 (в 17 степени) бит в секунду. У Пети нет скоростного доступа в Интернет, но есть

возможность получать информацию от Васи по низкоскоростному телефонному

каналу со средней скоростью 2(в 15 степени) бит в секунду. Петя

договорился с Васей, что тот будет скачивать для него данные объемом 4

Мбайта по высокоскоростному каналу и ретранслировать их Пете по

низкоскоростному каналу. Компьютер Васи может начать ретрансляцию данных

не раньше, чем им будут получены первые 512 Кбайт этих данных. Каков

минимально возможный промежуток времени (в секундах), с момента начала

скачивания Васей данных, до полного их получения Петей? В ответе укажите

только число, слово «секунд» или букву «с» добавлять не нужно.

бит в секунду.

Программирование на языке паскаль

вычислить значение у для х заданному с клавиатуры по формуле
y=1-x,если x<0
1+x,если x>10

Читайте также

Программа выполняется в Паскале! Составьте программу для решения следующей задачи:Дядюшка подарил своему племяннику на первый день

рождения 1 доллар. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет исполнилось его племяннику. Определите, к какому дню рождения сумма превысит 100 долларов? Помогите плииз.

Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В и С. Если они не равны, то замените все числа

наибольшим из них и выведите результаты на экран. Иначе, найдите и выведите сумму квадратов этих чисел.

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);



Вы находитесь на странице вопроса "Составить программу для решения следующей задачи: Дана последовательность символов,концом которой является точка.Подсчитать,сколько в этой", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.