Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Даны 3 целых числа A B C. Значение чисел воодится с клавиатуры. Написать программу для решения следующей задачи. Вывести на экран неотрицательные числа

5-9 класс

(не меньше 0). тема: Логические основы программирования

NasVet 31 авг. 2013 г., 13:07:30 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marmaritik
31 авг. 2013 г., 13:56:14 (10 лет назад)

var a,b,c:integer;

Begin

  read(a,b,c);

  if a>=0 then writeln(a);

  if b>=0 then writeln(b);

  if c>=0 then writeln(c);

End.

Ответить

Другие вопросы из категории

Помогите ответить на вопросы.Спасибо!

В чем состоит отличие микросхем флэш-памяти от микросхем оперативной памяти?
В чем состоит преимущество флэш-памяти перед магнитной и оптической долговременной памятью?
Какую последовательность кластеров занимает файл "файл 2" из приведенного примера на носителе информации?
Чем различаются таблицы размещения файлов FAT 12,FAT 16 и FAT 32?
Почему журналируемые файловые системы обеспечивают большую надежность хранения файлов?

вот задача 1 3 решите все
Примером числовой информации может служит:

а)текст в учебнике;
б)цены на товарах;
в)таблица умножения;
г)детская считалка.

Бабушка прислала Ивану посылку с яблоками и грушами. некоторые из этих плодов были большими, остальные- маленькими. По цвету плоды тоже различались: часть

плодов была желтого цвета, остальные- зеленого. Среди плодов было ни маленьких груш, ни маленьких зеленых яблок .Яблок было 25, а груш- 17. Больших плодов было 32. Желтых плодов было 28. зеленых яблок на два больше, чем зеленых груш. Иван угостил этими плодами своих друзей. Больше всего ребятам понравились большие желтые яблоки. Сколько было таких яблок?

Читайте также

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);

2. Определить, делится ли введенное число "а" на 3. Если делится то вывести на экран "Число делится на 3".Тип переменной определить самостоятельно. При

составлении условия учесть, что если число делится на 3, то то остаток от деления на 3 должен быть равен 0.

3. Дана программа на языке Паскаль.
var a,n,s: integer;
begin
s:=0;
n:=0;
repeat;
write('Введите число ');
readln(a);
s:=s+a;
n:=n+1;
until s>100;
writeln('Количество введенных чисел = ' ,n);
end.
Переписать программу используя цикл While.

4. Вывести на экран массив целых чисел, Состоящий из 15 элементов, значение которого из которых сгенерировано случайным образом из диапазона [20,60].

Дан массив из N элементов(12 элементов), заданный случайным образом от -10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N.

Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.



Вы находитесь на странице вопроса "Даны 3 целых числа A B C. Значение чисел воодится с клавиатуры. Написать программу для решения следующей задачи. Вывести на экран неотрицательные числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.