Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дано целое число А. Если значение А>0,то необходимо увеличить его на 4. Написать программу для решения этой задачи.

5-9 класс

Vasilinchuk84 15 марта 2015 г., 19:46:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lenpribytkowa
15 марта 2015 г., 20:44:51 (9 лет назад)

uses crt;
var a:integer;
begin
readln(a);
if a>0 then a:=a+4;
writeln(a);
end.

Ответить

Читайте также

срочно подскажите мне!!!!

Дано целое число А. Если значение А > 0, то необходимо
увеличить его на единицу. Разработать схему алгоритма для решения этой
задачи. Протестировать алгоритм для A=5, A=-4, A=0. сделать в паскале.


Программу я написала:

Program n1;
var A: real;
begin
readln (a);
if a>0
then a:=a+1;
writeln;
end.


правильно или нет? и какие у меня должны выходить значения?

1.Дано целое число N.Написать программу ,увеличивающую число в 3 раза ,если оно больше нуля

2.Дано целое число N.Написать программу ,заменяющую его нулём ,если больше или равно нулю,и увеличивающая его в 2 раза ,если число меньше нуля.
3 .Дано целые числа a и b .Написать программу , которая выводит сначала большее число ,затем меньшее.
4.Даны числа a,b,c.Написать программу ,выводящую их в возрастающем порядке.
ПЛИЗ ПОМОГИТЕ

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);



Вы находитесь на странице вопроса "Дано целое число А. Если значение А&gt;0,то необходимо увеличить его на 4. Написать программу для решения этой задачи.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.