Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В и С. Если они не равны, то замените все числа

5-9 класс

наибольшим из них и выведите результаты на экран. Иначе, найдите и выведите сумму квадратов этих чисел.

руслан232013 16 июля 2013 г., 21:25:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
P4ela7770
16 июля 2013 г., 23:06:03 (10 лет назад)

program abc;
var a,b,c:integer;
begin
readln(a,b,c);
if ((a=b) and (b=c) and (c=a)) then writeln(sqr(a)+sqr(b)+sqr(c))
else if (a>b) and (b>c) then begin b:=a; c:=a; writeln('a=',a,' b=',b,' c=',c) end
else if (b>a) and (c<b) then begin a:=b; c:=b; writeln('a=',a,' b=',b,' c=',c) end
else if (c>a) and (c>b) then begin a:=c; b:=c; writeln('a=',a,' b=',b,' c=',c) end;
end.

Ответить

Другие вопросы из категории

Помогите, римская система счисления

MCDXII

И наоборот 153

1.Вводится номер месяца. Надо определить к какому сезону относится этот месяц

2.Написать программу, которая грамотно печатает фразу "У меня К друзей". К вводится с клавиатуры. Например, для К=1 должно напечататься " У меня 1 друг", для К=24 - "У меня 24 друга", для К=100 - "У меня 100 друзей".

Решить в паскаль абс

Пожалуйста помогите!!

Читайте также

Программа выполняется в Паскале! Составьте программу для решения следующей задачи:Дядюшка подарил своему племяннику на первый день

рождения 1 доллар. В каждый следующий день рождения он удваивал свой подарок и прибавлял к нему столько долларов, сколько лет исполнилось его племяннику. Определите, к какому дню рождения сумма превысит 100 долларов? Помогите плииз.

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Напишите программу для решения следующей задачи. Камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округ

ляя значения скорости до целых чисел. Необходимо определить максимальную зарегистрированную скорость автомобиля. Если скорость хотя бы одного автомобиля была меньше 30 км\ч, выведите YES, иначе выведите NO.

Программа получает на вход число проехавших автомобилей N (1=<N=<30), затем указывает их скорости. Значение скорости не может быть меньше 1 и больше 300.

Программа должна сначала вывести максимальную скорость, затем YES или NO.

Написать на языке Паскаль

Пример работы программы: (смотри во вложениях)



Вы находитесь на странице вопроса "Составьте программу для решения следующей задачи. Введите с клавиатуры три числа: А, В и С. Если они не равны, то замените все числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.