Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

найдите и выведите на экран количество двузначных чисел у которых при умножении на 3 сумма цифр кратна 5

5-9 класс

Lenohka09 25 окт. 2014 г., 3:02:15 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Verik2002
25 окт. 2014 г., 5:54:37 (9 лет назад)

Program p1;

Uses crt;

Var i:byte;

    kol:integer;

Begin

 For i:= 10 to 99 do

  if i*3 div 10<10 then

    if ((i*3 mod 10)+(i*3 div 10)) mod 5=0 then

      kol:=kol+1

       else

  if ((i*3 mod 10)+(i*3 div 10)+(i*3 div 100)) mod 5=0  then

      kol:=kol+1;

Writeln('Количество чисел = ',kol);

End.

+ 0 -
Vikabaranova1
25 окт. 2014 г., 7:22:47 (9 лет назад)

var

  i, count:integer;

begin

  for i := 10 to 99 do

    if ( (i * 3) mod 10 + ((i * 3) div 10) mod 10 + (i * 3) div 100 ) mod 5 = 0 then

      inc(count);

  writeln('Count = ', count);

end.

Ответить

Другие вопросы из категории

1. Составьте программу ввода и вывода массива: 5, -2, 3, -6, 7, 9, -4, 8, 1, 2, 7, -3.

2. Составьте программу заполнения массива A(20) датчиком случайных чисел в диапазоне от -50 до 49 включительно.
3*. Составьте программу заполнения массива, не используя клавиатуру, числами: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19.

СРОЧНО!ПОЖАЛУЙСТА! Объем видеопамяти равен 512 Кб, разрешающая способность дисплея 320х200.

Сколько различных уровней яркостей принимает красная, зеленая и синяя
составляющие при условии, что видеопамять делится на две страницы?

СРОЧНО ПОМОГИТЕ ПОЖАЛУЙСТА

Запись числа 23 в системе счисления с основанием N выглядит так: 212. Укажите основание N этой системы счисления.

ПОМОГИТЕ!!!ПРОГРАММА НА ПАСКАЛЕ!!!

при каком последнем значение будет выполняться цикл
g:=0; while g<0 do g:=g-1


хелп ми!!!

Читайте также

Помогите пожалуйста, срочно надо.

Заранее большое спасибо)
1) Определите и выведите на экран количество четырехзначных чисел, которые делятся без остатка одновременно на 5 и 11.
2) Найдите и выведите на экран все двузначные числа, у которых при умножения на 2 сумма цифр увеличивается на 5.

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен значению текущего индекса, увеличенному на 3; 2-й равен квадрату предыдущего индекса; 3-й равен сумме двух предыдущих элементов. 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен сумме соответствующего элемента исходного массива и его индекса. В полученном массиве удвойте элементы,которые меньше заданного с клавиатуры числа А,и найдите их сумму . Выведите на экран исходные и полученные результаты .

Напишите программу, которая подсчитывает количество двузначных чисел в заданной последовательности натуральных чисел.Программа получает на вхо

д количество чисел в последовательности, а затем сами числа.Количество чисел не превышает 1000. Введённые числа не превышают 30 000.Программа должна вывести одно число – количество двузначных чисел в заданной последовательности натуральных чисел.



Вы находитесь на странице вопроса "найдите и выведите на экран количество двузначных чисел у которых при умножении на 3 сумма цифр кратна 5", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.