Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны два массива. Получить третий массив который на четных номерах элементы второго массива на нечетных элементы первого массива. решите пожалуйста

10-11 класс

через pascal ABC и опишите программу

Региночка0070 25 апр. 2014 г., 5:36:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gotanja74
25 апр. 2014 г., 8:20:14 (10 лет назад)

Количество элементов в массивах одинаковое и равно n.
a - первый массив
b - второй массив
c - третий массив
i - цикловая переменная, индекс элемента массива

var
a, b, c : array [1..100] of integer;
n, i : integer;
begin
readln (n);
for i := 1 to n do
readln (a [ i ]);
[ввели первый массив]
for i := 1 to n do
readln (b [ i ]);
[ввели второй массив]
for i := 1 to n do
begin
if i mod 2 = 0 then  [проверка индекса элемента на чётность] 
c [ i ] = b [ i ];
else
c [ i ] = a [ i ];
end;
[создали третий] 
for i := 1 to n do
writeln (c [ i ] : 4);
[вывод третьего массива]
end.

Можно всё это сделать одним циклом.

var
a, b, c : array [1..100] of integer;
n, i : integer;
begin
readln (n);
for i := 1 to n do
begin
readln (a [ i ]);
readln (b [ i ]);
if i mod 2 = 0 then
c [ i ] = b [ i ];
else
c [ i ] = a [ i ];
writeln (c [ i ] : 4);
end;
end.

+ 0 -
Maksim7873
25 апр. 2014 г., 10:38:14 (10 лет назад)

uses crt; {подключение модуля crt}
var {описание переменных}
   a,b,c:array [1..100] of integer;
  i:integer;
begin
  write('Введи количество элементов массива: '); read(i); {вывод текста на экран и чтение вводимых данных}
  clrscr; {очистка экрана}
  writeln('Первый массив: '); {вывод текста на экран}
  for i:=1 to i do {цикл}
  begin
    a[i]:=random(10); {значения первого массива от 0 до 9}
    b[i]:=random(10)-10; {значения второго массива от -10 до -1}
    if i mod 2=0 then c[i]:=b[i] {четные элементы третьего массива}
      else c[i]:=a[i]; {нечетные элементы третьего массива}
    write(a[i]:4); {вывод на экран первого массива}
  end; {конец цкла}
  writeln; writeln('Второй массив'); {вывод текста на экран}
  for i:=1 to i do {цикл}
    write(b[i]:4); {вывод второго массива на экран}
  writeln; writeln('Третий массив:'); {вывод текста}
  for i:=1 to i do {цикл}
    write(c[i]:4); {вывод третьего массива}
end.

Ответить

Другие вопросы из категории

чему равен 10*5 в двоичной системе?

варианты ответов
А) 01010101
В) 00110010
С) 00011101
Д) 11001100
Е) 10101010

Решите задачу (см.вложение).
Нерввы на пределе, завтра сдавать, а в процедуре организовать не получается... Составить программу для решения следующей задачи: Дана строка.

Зашифровать ее, переворачивая каждое слово. Создать процедуры для разбиения строки на слова и записи слова в обратном порядке.

Привет, Вася!

!ясаВ ,тевирП

Читайте также

Даны два массива А и В, состоящие из 6 элементов.

Объединить два массива в один массив с чередованием элементов исходных
массивов. Вывести новый массив.
паскаль.

Паскаль. 12.Дан массив А(3*4). Найти сумму первых отрицательных элементов в каждом столбце. 13.Даны два массива А(3*3)

и В(3*3). Вывести на экран тот из них, у которого меньше сумма элементов главной диагонали.

17.Дан массив А(3*4). Заменить все отрицательные элементы на противоположные.

Задан одномерный массив А(N) (N<=60). На место минимального элемента массива записать сумму последних К элементов массива. Если А[1]>=0, то умножить

все элементы этого массива на квадрат минимального элемента данного вектора, а если А[1]<0, то умножить все элементы на квадрат максимального элемента вектора. Полученный массив распечатать. Значение К вводится пользователем.

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

1.Даны два массива: А(5) и В(5). Сформируйте из них массив С,предварительно определив его длину,включая попеременно из массива А положительные

элементы, а из массива В -нечетные по значению.Выведите на экран массивы А,В,С.

2.Информация о площадях и средней урожайности хранится в массиве,где каждый элемент с четным индексом - засеянная площадь, а с нечетным - урожайность.Определите и выведите на экран кол-во собранной пшеницы и среднюю урожайность.

Помогите пожалуйста!



Вы находитесь на странице вопроса "Даны два массива. Получить третий массив который на четных номерах элементы второго массива на нечетных элементы первого массива. решите пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.