Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана исходная строка: “12”. Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных

10-11 класс

позициях считая слева направо, прибавили по 1. Получилась строка: “1322”. Указанный алгоритм обработки применили к этой получившейся строке, затем к строке, которая получилась в результате новой обработки и т.д. Например, после трех применений алгоритма обработки получились следующие строки:

12

1322

14232332

1524243324333342

Посчитай количество нечетных цифр в строке, получившейся после шестого применения алгоритма обработки. В ответе укажите целое число.

Настюшка675849 18 янв. 2015 г., 13:23:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tremvana
18 янв. 2015 г., 14:23:34 (9 лет назад)

Program test;
var i,n,k,s1,es,al:integer;
s:string;
begin
write('Введите кол-во повторений:');
readln(n);
write('Введите строку:');
readln(s);
repeat
inc(k);
for i:=length(s) downto 1 do s:=s+s[i];
for i:=1 to length(s) do
if i mod 2 = 0 then
begin
es:=strtoInt(s[i])+1;
delete(s,i,1);
insert(InttoStr(es),s,i);
end;
writeln(k,') ',s);
until k=n;
for i:=1 to length(s) do
if StrtoInt(s[i]) mod 2 = 1 then inc(al);
writeln('Кол-во нечетных чисел: ',al);
end.

Ответить

Другие вопросы из категории

Средствами Microsoft Excel составить рабочий календарь.

Порядок работы. Заполнить таблицу произвольным образом (например, см. рис.). Используя встроенные функции Excel, в столбце Сообщение вывести одно из двух текстовых сообщений:
1)«Выполнить», если Дата выполнения совпадает с текущей датой
2) «–», если Дата выполнения не совпадает с текущей датой.




Пропускная способность канала связи 10 Мбит/с. Канал подвержен воздействию шума, поэтому избыточность кода составляет 20%. Определите, за сколько времени

по каналу будет передан текст, информационный объем которого составляет 100 Кб.

Читайте также

Строки (цепочки символов латинских букв) создаются по следующему правилу. Первая строка содержит одну латинскую букву «А». Каждая из последующих

цепочек создается такими действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите со-ответствует номеру строки , к ней справа дважды подряд приписывается предыдущая строка. Вот первые 4 строки, созданные по этому правилу: (1) A (2) BAA (3) CBAABAA (4) DCBAABAACBAABAA Латинский алфавит (для справки): ABCDEFGHIJKLMNOPQRSTUVWXYZ Запишите четыре символа подряд, стоящие в седьмой строке со 120-го по 123-е место (считая слева направо).

Цепочка символов создаётся по следующему правилу. Первая строка содержит одну латинскую букву «А». Каждая из последующих цепочек создается такими

действиями: в очередную строку сначала записывается буква, чей порядковый номер в алфавите соответствует номеру строки, к ней справа дважды подряд приписывается предыдущая строка. Вот первые 4 строки, созданные по этому правилу:

(1) A

(2) BAA

(3) CBAABAA

(4) DCBAABAACBAABAA

Латинский алфавит (для справки): ABCDEFGHIJKLMNOPQRSTUVWXYZ

Запишите четыре символа подряд, стоящие в седьмой строке со 120-го по 123-е место (считая слева направо).

Для вывода на экран произвольной символьной строки нужно в команде вывода записать эту строку в апострофах. Например, по команде вывод "ОТВЕТ"

на экран выведется слово ОТВЕТ.

Определите, какая задача решается по следующему алгоритму:

алг Задача-6
вещ X
нач ввод X
если Х < 0
то вывод "отрицательное число"
иначе вывод "положительное число"
кв
кон

дано массивы A(N1,N1),B(N2,N2),C(N3,N3). найти в каждой строке исходного массива наименьший элемент и переставить его с элементом стоящим на главной

диагонали. нахождение в каждой строке массива наименьшего элемента и его перестановку с элементом стоящим на главной диагонали оформить в виде подпрограммы

Дана квадратная матрица размера N. Если сумма элементов по главной диагонали больше суммы элементов на побочной диагонали, то заменить элементы стоящие на

четных местах в строке на “ * ”, а элементы стоящие на нечетных местах в строке на ноль.



Вы находитесь на странице вопроса "Дана исходная строка: “12”. Ее обработали по следующему алгоритму: в конец строки дописали ее зеркальную копию, а затем к цифрам стоящим на четных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.