Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите написать программы >< Задача 1: Среди целых чисел найти минимальное число, которое больше 20 и делится на 17. Задача 2:

5-9 класс

Найти максимальное натуральное число меньше 5000, которое делится нацело на 39.

Задача 3: 1 марта в банк положили 1000 руб. Каждый месяц вклад увеличивается на 2% от имеющейся суммы.

а) за какой месяц величина процентной надбавки превысит 30 руб.?

б) через сколько месяцев размер вклада превысит 1200 руб.? Заранее спасибо)

Nastyaef2000 09 апр. 2015 г., 15:58:39 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ylia61
09 апр. 2015 г., 17:17:36 (9 лет назад)

var

  i : integer;

begin

  i := 21;

  while i mod 17 <> 0 do i := i + 1;

  writeln (i);

end.

 

var

  i : integer;

begin

  i := 4999;

  while i mod 39 <> 0 do i := i - 1;

  writeln (i);

end.

 

var

  i : real;

  c : integer;

begin

  c := 0;

  i := 1000;

  while i * 0.02 <= 30 do

  begin

    c := c + 1;

    i := i * 1.02;

  end;

  writeln (c + 1);

end.

 

var

  i : real;

  c : integer;

begin

  c := 0;

  i := 1000;

  while i <= 1200 do

  begin

    c := c + 1;

    i := i * 1.02;

  end;

  writeln (c);

end.

Ответить

Другие вопросы из категории

Решите !!! Пожалуйста !!!
Составить программу Pascal:

Проверить , кратно ли 2 сумма двух натуральных чисел .

отметьте технические системы

Солнечная система
футбольная команда

что такое Локальная сеть?

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

ПОМОГИТЕ НАПИСАТЬ ХОТЯ БЫ ОДНУ ЗАДАЧУ НА Pascal ОНИ НЕ СЛОЖНЫЕ , А Я ДАЮ МНОГО ПУНКТОВ!! За 2 лучший ответ! Без плагиата! 1.Написать

программу,используя оператор цикла While,которая будет вводить целые положительные числа не превышающие 100. Найти сумму квадратов чисел 2.Написать программу используя оператор цикла Repeat,которая будет вводить целые числа до тех пор пока не будет введён 0.Подсчитать среднее арифметическое введённых чисел.

Помогите написать программу на Паскале.

Напишите программу, которая в последовательности целых чисел
вычисляет сумму всех чисел, которые кратны 6 или 11. Программа получает на вход
целые числа, количество введённых чисел неизвестно, последовательность чисел
заканчивается числом 0 (0 – признак окончания ввода, не входит
в последовательность).

Количество чисел не превышает 1000. Введённые числа по
модулю не превышают 30 000.

Программа должна вывести одно число: сумму всех чисел,
которые кратны 6 или 11.






Помогите построить блок схему к задаче

После очередного этапа чемпионата мира по кольцевым автогонкам на автомобилях с открытыми колесами Формула-А гонщики собрались вместе в кафе, чтобы обсудить полученные результаты. Они вспомнили, что в молодости соревновались не на больших болидах, а на картах – спортивных автомобилях меньших размеров.
Друзья решили выяснить победителя в одной из гонок на картах. Победителем гонки являлся тот гонщик, у которого суммарное время прохождения всех кругов трассы было минимальным.
Поскольку окончательные результаты не сохранились, то каждый из n участников той гонки вспомнил и выписал результаты прохождения каждого из m кругов трассы. К сожалению, гонщикам было сложно вычислить победителя той гонки. В связи с этим они попросили сделать это вас.
Требуется написать программу, которая вычислит победителя гонки на картах, о которой говорили гонщики.
Формат входных данных
Первая строка входных данных содержит два целых числа n и m (1 ≤ n, m ≤ 100). Последующие 2∙n строк описывают прохождение трассы каждым из участников. Описание прохождения трассы участником состоит из двух строк. Первая строка содержит имя участника с использованием только латинских букв (строчных и заглавных). Имена всех участников различны, строчные и заглавные буквы в именах различаются.
Вторая строка содержит m положительных целых чисел, где каждое число – это время прохождения данным участником каждого из m кругов трассы (каждое из этих чисел не превосходит 1000). Длина каждой строки не превышает 255 символов.
Формат выходных данных
В выходные данные необходимо вывести имя победителя гонки на картах. Если победителей несколько, требуется вывести имя любого из них.
Пример входных и выходных данных

Входные данные
Выходные данные
5 3
Sumaher
2 1 1
Barikelo
2 1 2
Olonso
1 2 1
Vasya
1 1 1
Fedya
1 1 1
Fedya



Вы находитесь на странице вопроса "Помогите написать программы &gt;&lt; Задача 1: Среди целых чисел найти минимальное число, которое больше 20 и делится на 17. Задача 2:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.