Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль!!1Даны катеты прямоугольного треугольника. Найти его периметр

10-11 класс

2даны основания и высота равнобедренной трапеции найти ее периметр
3дано расстояние в сантиметрах найти число полных метров в нем

89082432418 16 окт. 2016 г., 23:11:00 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kristuna07
17 окт. 2016 г., 1:58:38 (7 лет назад)

В файле все 3 задачи.

+ 0 -
KUBE684
17 окт. 2016 г., 4:55:50 (7 лет назад)

Program Vby_1;
uses crt;
var a,b,c:real;
begin
  writeln('***   Alphaues is thinking...   ***');
  writeln('Ok, введите катеты: ');
  write('a= ');readln(a);
  write('b= ');readln(b);
  writeln('Периметр прямоугольного треугольника = ',a+b+sqrt(a*a+b*b):8:2);
end.

Program Vby_2;
uses crt;
var a,b,h,t:real;
begin
  writeln('***   Alphaues is thinking...   ***');
  writeln('Ok, введите данные: ');
  write('Одно основание = ');readln(a);
  write('Другое основание = ');readln(b);
  write('Высота = ');readln(h);
  t:=abs(a-b)/2;
writeln('Периметр трапеции =',a+b+sqrt(h*h+t*t):8:2);
end.

Program Vby_3;
uses crt;
var s:integer;
begin
  writeln('***   Alphaues is thinking...   ***');
  write('Ok, введите расстояние в сантиметрах: '); readln(s);
  write('Число полных метров = ',s div 100);
end.

+ 0 -
Emiktor
17 окт. 2016 г., 6:46:46 (7 лет назад)

Да, правильно третью сделал)

+ 0 -
алинёночек
17 окт. 2016 г., 8:29:02 (7 лет назад)

Bristel, зачем тебе модуль crt в этой задаче? В ней не используется ни одной функции из этого модуля.

+ 0 -
Юля199629
17 окт. 2016 г., 9:28:07 (7 лет назад)

мне удобней водить данные в отдельном окне так как стандартное меня бесит и я люблю постоянно разукрашивать фон и текст но в данной задаче я этого не делал

+ 0 -
Erzh1707
17 окт. 2016 г., 10:02:49 (7 лет назад)

Я ведь и говорю про данную задачу, лишняя строка)

+ 0 -
YXXon
17 окт. 2016 г., 11:09:00 (7 лет назад)

))

Ответить

Другие вопросы из категории

20ГБ это сколько в байтах?
Как визуально определить, что команда "не работает"?

Вариант 1:по трем точкам в конце команды
Вариант 2:по стрелке вправо в конце команды
Вариант 3:по "галочке" слева от команды
Вариант 4:по цвету строки с командой

Читайте также

Это по JAVE!помогите пожалуйста!

даны катеты прямоугольного треугольника.найти его гипотенузу

1. По сторонам треугольника найти его периметр, площадь, высоты и радиус вписанного и описаного кругов.

2. Найти больше из трех данных чисел.
3. В одномерном массиве положительные элементы меншиты на 7.

помогите решить пожалуйста. по паскалю 1. а) вычисления значения функции у = 7х2 - 3х + 6 при любом значении х;

б) вычисления значения функции х = 12а2 + 7а — 16 при любом значении а.

2.

даны катеты прямоугольного треугольника. Найти его гипотенузу

ребяят нужна помощь!!!

напишите программу в паскале, для построения прямоугольного треугольника с обозначением прямого угла, вершин, и подписать катеты и гипотенузу... выручайте!!!



Вы находитесь на странице вопроса "Паскаль!!1Даны катеты прямоугольного треугольника. Найти его периметр", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.