Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

1. По сторонам треугольника найти его периметр, площадь, высоты и радиус вписанного и описаного кругов.

10-11 класс

2. Найти больше из трех данных чисел.
3. В одномерном массиве положительные элементы меншиты на 7.

Rhbcrf2013 23 февр. 2015 г., 20:27:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Никита124
23 февр. 2015 г., 23:19:20 (9 лет назад)

var
  a,b,c,p,p2,s,h1,h2,h3,r,rv:real;
begin
readln(a,b,c);
p:=a+b+c;
p2:=p/2;
s:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
h1:=2*s/a;
h2:=2*s/b;
h3:=2*s/c;
r:=a*b*c/4/s;
rv:=s/p2;
writeln('p=',p);
writeln('s=',s);
writeln('Высоты: ',h1,' ',h2,' ',h3);
writeln('Радиус вписанной окружности: ',rv);
writeln('Радиус описанной окружности: ',r);
end.

var
  a,b,c,max:real;
begin
readln(a);
max:=a;
readln(b);
if b>max then max:=b;
readln(c);
if c>max then max:=c;
writeln('Наибольшее: ',max);
end.

var
  i:integer;
  a:array[1..10]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 10 do
  begin
  a[i]:=random(-10,10);
  write(a[i],' ');
  end;
writeln;
writeln('Измененный массив:');
for i:=1 to 10 do
  begin
  if a[i]>0 then a[i]:=a[i]-7;
  write(a[i],' ');
  end;
 end.

Ответить

Другие вопросы из категории

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

Ребята, напишите, пожалуйста, программу.

Заранее спасибо.

C++Написать программу вычисления объема параллелепипеда. Ниже представлен рекомендуемый вид экрана во время работы программы (данные, введенные

пользователем, выделены полужирным шрифтом).

Вычисление объема параллелепипеда.

Введите исходные данные:

Длинна (см): 9

Ширина (см): 7.5

Высота (см): 5



Вы находитесь на странице вопроса "1. По сторонам треугольника найти его периметр, площадь, высоты и радиус вписанного и описаного кругов.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.