Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Необходимо РЕШЕНИЕ.

5-9 класс

Для регистрации на сайте некоторой страны пользователю требуется придумать пароль. Длина пароля - ровно 11 символов. В качестве символов используются десятичные цифры и 12 различных букв местного алфавита, причем все буквы используются в двух начертаниях: как строчные, так и заглавные. Под хранение каждого такого пароля на компьютере отводится минимально возможное и одинаковое целое количество байтов, при этом используется посимвольное кодирование и все символы кодируются одинаковым и минимально возможным количеством битов. Определите объем памяти, который занимает хранение 60 паролей.

2002катюшенька2002 23 янв. 2015 г., 1:56:31 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Настя250520
23 янв. 2015 г., 4:27:31 (9 лет назад)

В алфавите 34 символа (10 цифр + 24 буквы), => для одного символа используется 34 \leq 2^{6} , 6 бит

Для одного пароля требуется 11 символов, 11*6 = 66 бит на пароль, переведём в байты => 9 байт (66/8=8.25, но требуется ближайшее большее целое).

60 паролей * 9 байт = 540 байт.

Ответить

Другие вопросы из категории

Читайте также

1.Составьте блок-схему для решения задачи: Найти площадь S и периметр P прямоугольника. Значения сторон а и в задать произвольно.

2.Составить блок - схему кипячения чайника.

3.Составить алгоритм сбора яблок в саду.Ваша задача сводится к тому,что необходимо собрать ведро яблок с земли.

4.Составьте алгоритм на формальном языке и блок - схему для решения следущего примера : y=5x+6,если х=3

чтобы добраться до намеченного места, Пете необходимо преодолеть 32 км У пети есть скутер, который развивает скорость 40 магических миль/час. В 5

магических милях 8 км. За сколько минут до назначенного времени необходимо выехать Пете, чтобы добраться до места встречи вовремя? |15 мин.| 30 мин.| 45 мин.| 60 мин.|

Самолёт находился на высоте 5000 метров. Обнаружилась неисправность работы двигателя. Самолёт начал падать. Бортовой компьютер производит диагностику неисп

равности и сообщает пилоту о необходимых действиях. Для решения этой задачи ему нужно выполнить 100000000 вычислительных операций. Быстродействие компьютера - 1 млн. оп./с. Успеет ли лётчик спасти самолёт, если минимальная высота, на которой самолёт можно вывести из пике, - 2000 метров?

написать программу которая вычисляет оптимальный вес пользователя сравнивая его с реальными выдаёт рекомендации о необходимости поправиться или

похудеть.по формуле рост минус 100...

написать то легко но учитель сказал что б говорилось на сколько худеть или поправиться надо ...(( ну ни как не могу додуматься(( помогите (( вот сама написаная программа

Program Zadacha1;
Var ves, rost, optVes:integer;
Begin
write('введите массу тела');
read(ves);
write('введите рост в см');
read(rost);
optVes:=rost-100;
if ves>optVes then write('вам необходимо похудеть' );
if ves<optVes then write('вам необходимо поправиться');
if ves=optVes then write ('ваш вес оптимальный')
End.

Пусть А - это стакан с чаем, а В - чашка кофе. Необходимо перелить кофе в стакан, а чай - в чашку так, чтобы напитки не смешались. Можно ли

рассматривать следующую блок-схему как модель решения поставленной задачи? Какая роль здесь отводится М? начало ! А,В,М ! М:=А ! А:=В ! В:=М ! конец



Вы находитесь на странице вопроса "Необходимо РЕШЕНИЕ.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.