Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

по введённому номеру года выдать какой это год по восточному календарю.плиз ответьте развёрнуто и понятно.нужно написать в программе паскаль

5-9 класс

Арина4444 08 мая 2015 г., 2:06:01 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mamontova09
08 мая 2015 г., 3:29:16 (8 лет назад)

Начало отсчета лет - 1984 год. Надо написать программу (pascalABC). Вводите год, нужный вам, отнимаете от него 1984 и находите остаток от деления на 12. Последовательность животных в 12-летнем цикле - крыса, корова, тигр, заяц, дракон, змея, лошадь, овца, обезьяна, курица, собака, свинья. То есть если при делении на 12 остаток равен 0, значит введенный год - год крысы, если 1 - год коровы и т.д.

Программа: 

var a,b,c:longint;
begin
write('Введите год: ');
readln(a);
c:=a-1984;
b:=c mod 12;
case b of
0:writeln(a,' - год крысы');
1:writeln(a,' - год коровы');
2:writeln(a,' - год тигра');
3:writeln(a,' - год зайца');
4:writeln(a,' - год дракона');
5:writeln(a,' - год змеи');
6:writeln(a,' - год лошади');
7:writeln(a,' - год овцы');
8:writeln(a,' - год обезьяны');
9:writeln(a,' - год курицы');
10:writeln(a,' - год собаки');
11:writeln(a,' - год свиньи');
end;
end.

Ответить

Читайте также

Какие события произошли в указанные даты? 1) 1946 год — 2) 1842 год — 3) 1880 год — 4) 1951 год — 5) 1876 год — 6) 1969 год — 7) 80-е годы XX века — 8)

1963 год — в Америке изобретен телефон в США начала функционировать первая в мире компьютерная сеть под руководством С.А.Лебедева создана первая советская ЭВМ год рождения компьютерной мышки появление первой ЭВМ, созданной Маучли и Эккертом Блез Паскаль изобрел «Паскалину» В.Т.Однер изобрел арифмометр появление первых лазерных дисков.



Вы находитесь на странице вопроса "по введённому номеру года выдать какой это год по восточному календарю.плиз ответьте развёрнуто и понятно.нужно написать в программе паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.