Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Сформировать последовательность 20 членов чисел фибоначи

10-11 класс

Vikula1202 02 июня 2013 г., 18:56:17 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kristinapronin
02 июня 2013 г., 20:19:48 (10 лет назад)

#include <iostream>
using namespace std; 
int main()
{   
unsigned int n1=0, n2=1;      
unsigned int n;   
int i=0;    
do   
{       
cout << n1 << " ";       
n = n1 + n2;       
n1 = n2;       
n2 = n;       
i++;   
} while(i<20);    
cout << endl;    
system("pause");   
return 0;               
}

Ответить

Другие вопросы из категории

правильно же или что-то не понимаю?
Вводятся 4 числа: a, b, c и d.

Найдите все целые решения уравнения

Читайте также

Выводится на экран последовательность 20 случайных чисел из промежутка

[-10,10]. Определить количество отрицательных чисел больших -5 в данной
последовательности.

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.



Вы находитесь на странице вопроса "Сформировать последовательность 20 членов чисел фибоначи", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.