Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В массиве из 10 целых чисел подсчитать сумму

10-11 класс

элементов, стоящих правее минимального. на паскале

Nataliarwanova 03 апр. 2016 г., 18:20:21 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
анг
03 апр. 2016 г., 19:12:28 (8 лет назад)

uses crt;
const n=10;
var a:array[1..n] of integer;
s,i,min,k:integer;
begin
min:=1000;
for i:=1 to n do
begin
readln(a[i]);
if a[i]<min then begin min:=a[i]; k:=i; end;
end;
s:=0;
for i:=k+1 to n do
s:=s+a[i];
writeln(s);
end.



Ответить

Другие вопросы из категории

Устройство, предназначенное для согласования кабеля и предотвращающее появление отраженного сигнала, подсоединяемое на концах шины и к незанятым разъемам

пассивного разветвителя.


1) терминатор

2) активатор

3) концентратор

4) адаптер

5) коннектор

составить программу которая вводит с клавиатуры длину стороны квадрата вещественного типа и выводит на экран дисплея площадь квадрата.

процедура P1 вводит с клавиатуры длину стороны квадрата;

функция F1 вычисляет площадь квадрата;

Процедура P2 выводит на экран результат.

процедура P1 и функции F1 - встроенный в программу

процедура P2 - записывается как отдельный модуль подключаемый к основной программе.

в паскале

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1. Написать программу, которая выводит на экран сумму средних арифметических значений двух вещественных массивов из 10 элементов.

2. Написать прогрумму,которая выводит на экран, разность значений двух вещественных массивов из 10 элементов.

Помогите решить люди).

Подсчитайте количество нулевых элементов в массиве из 10 целых чисел и распечатайте исходный массив в обратном порядке.



Вы находитесь на странице вопроса "В массиве из 10 целых чисел подсчитать сумму", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.