Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

паскаль см. вложение циклы

10-11 класс

TimyrDzhanaev 29 мая 2013 г., 4:10:19 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Zubkoruslanka
29 мая 2013 г., 5:05:33 (10 лет назад)

var
a, b, c, xn, xk, h, f: Real;
begin

Write('Введите Xn: '); Readln(xn);
Write('Введите Xk: '); Readln(xk);
Write('Введите шаг H: '); Readln(h);
Write('Введите a: '); Readln(a);
Write('Введите b: '); Readln(b);
Write('Введите c: '); Readln(c);


while xn <= xk do
begin
if (c < 0) and (b <> 0) then
f := a * sqr(xn) + sqr(b) * xn
else if (c > 0) and (b = 0) then
f := (xn + a) / (xn + c)
else
f := xn / c;

Writeln(xn:0:3, ' | ', f:0:3);  // таблицу сам оформишь

xn := xn + h;
end;

Readln;
end.

+ 0 -
Пацифист
29 мая 2013 г., 7:17:16 (10 лет назад)

Program pr;
uses crt;
Var a,b,c:integer;
    H,F,x,x1,x2:real;

Begin
Writeln('Шаг');
readln(H);
Writeln(' a,b,c');
readln(a,b,c);
Writeln('промежуток X нач ,X кон ');
readln(x1,x2);
x:=x1;
While x<=x2 do
   Begin
 if (c<0) and (b<>0) then
        Begin
          F:=(a*x*x)+(b*b*x);
          Writeln('x=', x:6:2, ' F=',F:6:2);
          x:=x+H;
        end
 else
if (c>0) and (b=0) then
        Begin
         F:=(x+a)/(x+c);
         Writeln('x=', x:6:2, ' F=',F:6:2);
         x:=x+H;
        end
else
 Begin
F:=x/c;
Writeln('x=', x:6:2, ' F=',F:6:2);
 x:=x+H;
end;


end;
readln;
end.

Ответить

Другие вопросы из категории

Для адресации в сети с протоколом IPv4 используется следующий адрес ограниченного широковещания: 192.168.7.255, а служебный адрес IP-сети: 192.168.0.0.

Какова маска данной сети. Ответ запишите как четыре десятичных числа, разделенных точками, например "255.0.0.0".

Читайте также

Помогите, пожалуйста.

В паскале.

найти все двузначные числа, сумма кубов цифр которых делится на 17. (использовать вложенные циклы)

См вложения ПОЖАЛУЙСТА,Напишите программу в Паскале. 1)надо чтоб интервал и заполение были рандом. 2) надо показать целую таблицу

3) надо показать таблицу после выреза, должена остататься только таблица, которая внутри (маленький квадратик)

Помогите исправить ошибки Задание: составить программу на яз. Паскаль с использованием цикла с неизвестным числом повторений для вычислений значения

функции F(x)=sin(x)+tg(x) на отрезке [А, В] при изменении аргумента в точках хi = А+iН, где Н – шаг. А=1, В=2, Н=0,125.

Листинг программы:

Program Tabulir;

Var x, y: real;

Begin x:=1;

While x≤2 do begin

y:=sin(x)+tg(x);

writeln (x:9:1, y:16:3);

x:=x+0,125;

End.



Вы находитесь на странице вопроса "паскаль см. вложение циклы", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.