Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Нахождение максимального и минимального элемента массива (Из сгенерированного из 10000 целых чисел, используя random(k))

5-9 класс

Iren2808 01 окт. 2013 г., 7:00:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maria82
01 окт. 2013 г., 8:45:25 (10 лет назад)

const
  n = 10000;

var
  a: array[1..n] of integer;
  i, mx, mn: integer;

begin
  Randomize;
  mx := -7777777; mn := 7777777;
  for i := 1 to n do
  begin
    a[i] := Random(20001) - 10000;
    if mx < a[i] then mx := a[i]
    else if mn > a[i] then mn := a[i]
  end; 
  Writeln('Min=', mn, ', max=', mx)
end.

Тестовое решение:

Min=-10000, max=9999


Ответить

Читайте также

1) Удвоить все элементы массива. 2)Найти сумму элементов двух массивов одинаковой размерности. 4) Найти Минимальные элементы массива и

его индекс.

5) Найти максимальные элементы среди положительных элементов массива 6) Найти максимальные элементы среди отрицательных элементов массива

7) Определить количество максимальных элементов массива

P.S Ребят, все в паскале...заранее спасибо=*

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

Дается последовательность из N чисел. Выведите разницу между максимальным и минимальным элементами последовательности.

Формат входных данных
Первая строка входного файла содержит целое число N (1 <= N <= 100000). В следующей строке задаются N положительных целых чисел, каждое из которых не превышает 100000.
Формат выходных данных
Выведите ответ к задаче.

Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С,В которые содержат: массив В - четные элементы из

массива А в порядке их следования в массиве А, массив С- отрицательные элементы массива А в порядке, обратному их следованию в массиве А.



Вы находитесь на странице вопроса "Нахождение максимального и минимального элемента массива (Из сгенерированного из 10000 целых чисел, используя random(k))", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.