Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дана последовательность целых чисел x1 x2 xn и натуральное n получить последовательность чисел кратных 3 и не кратных 5 заранее спасибо)

5-9 класс

Lenahoney2001 07 марта 2014 г., 13:37:24 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
89605426236
07 марта 2014 г., 14:23:48 (10 лет назад)

var

 i,n,a:integer;

begin

 readln(n);

for i:=1 to n do

begin

 read(a);

if (a mod 3=0)and(a mod 5>0) then write(a,' ');

end;

writeln;

end.

Ответить

Другие вопросы из категории

Выберите наиболее удачное имя для файла с письмом другу!

Докумени5
Рыбалка
Письмо
Письмо_Пете
Помогите пожалуйста завтра задание будут проверять и оценки за четверть выводить))

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

1)Напишите программу,которая в последовательности целых чисел определяет количество трехзначных чисел,не кратных 5 и 7 и не заканчивающ

ихся 0 или 1.
Программа получает на вход целые числа от -3000 до 3000.

2)Напишите программу,которая в последовательности целых чисел вычисляет среднее арифметическое среди двухзначных чётных чисел,делящихся на 3.
НУЖНО СЕГОДНЯ! 66 БАЛЛОВ!

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "дана последовательность целых чисел x1 x2 xn и натуральное n получить последовательность чисел кратных 3 и не кратных 5 заранее спасибо)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.