Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

С#, консоль

10-11 класс

Дан целочисленный массив размера N. Вставить после каждой его серии элемент с нулевым значением. Серия - это группа подряд идущих одинаковых элементов, длина серии — количество этих элементов (длина серии может быть равна 1).

April95 16 апр. 2015 г., 12:04:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
анна302
16 апр. 2015 г., 14:38:25 (9 лет назад)

using System;

static void Main()
{
        int[] sourceArray = new int[] {3, 1, -4, -4, 65};                  //Исходный массив
        int[] newArray = new int[sourceArray.Length * 2];                  //Новый массив с максимальной нужной длиной
        int newArrayIndex = 0;                                             //Индекс для нового массива
        for (int i = 0; i < sourceArray.Length; i++)
        {
                newArray[newArrayIndex++] = sourceArray[i];
                if (i == sourceArray.Length - 1 || sourceArray[i] != sourceArray[i + 1])
                        newArray[newArrayIndex++] = 0;
        }
        for (int i = 0; i < newArrayIndex; i++)                            //Выводим новый массив на экран
                Console.Write(newArray[i] + " ");
        Console.ReadKey();
}

Ответить

Другие вопросы из категории

Помогитеее!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
1)Региональная метеостанция фиксирует годовые атмосферные осадки в 128 населенных пунктах. За 5 лет наблюдений колебания осадков были в интервале от

100 до 900 мм. Специальное устройство записывает величину осадков в двоичном коде с использованием минимально возможного количества битов. Каков информационный объем (в байтах) всех данных, записанных устройством за эти годы? В ответе укажите только число.

Читайте также

Помогите в с++ билдер. В строке, состоящей из групп нулей и единиц, подсчитать количество символов в самой длинной группе.(напишите код в консоли)...

вот пример который считает количество едениц в строках с нечётным количеством символов
//---------------------------------------------------------------------------

#include
#include
#include
#include
#pragma hdrstop

//---------------------------------------------------------------------------

#pragma argsused
int main(int argc, char* argv[])
{
int n,s, i, nst,p,k, len,t=0;
char a[81];
puts(" Input string ");
gets(a);
len = strlen(a);
s=0;
n=0;
a[len+1]='\0';
a[len]=' ';
for(i=0; i<=len; i++)
{
if(a[i]!=' ')
{
n++;
if(a[i]=='1')
t++;
}
else
{
if(n%2!=0)s+=t;
n=0;
t=0;
}
}
printf("\nkoli4ectvo 1= %d", s);
puts("\nPress any key to close ... ");
getch();
return 0;
}
//---------------------------------------------------------------------------

Сделайте архивный файл (rar) через консоль Windows (cmd). В файл поместите doc-документ, содержащий ваши Ф.И.О, номер группы и текст команды, которую вы

используете.


Объясните пожалуйста как это сделать , какую именно нужно команду ввести .... в Инете искал не нашёл )) помогите поже...

C#, консоль

Дана строка S. Разделить строку на отдельные слова не используя стандартные средства для разбиения строк



Вы находитесь на странице вопроса "С#, консоль", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.