Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

только что увидила что есть еще последняя задача ))) дан одновременный массив из п положительных чисел . составить программу вычисления их : сред

10-11 класс

него геометрического

Glazovaa 20 марта 2015 г., 2:10:42 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vlad0090802
20 марта 2015 г., 3:03:12 (9 лет назад)

var
a: array [1..100] of integer;
i, n, с: integer;
s : longint;
begin
readln (n);
for i := 1 to n do read (a[i]);
s := 1;
с := 0;
for i := 1 to n do
begin
s:=s*a[i];
inc(с);
end;
writeln (exp((1/с)*ln(s)));
end.

Ответить

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "только что увидила что есть еще последняя задача ))) дан одновременный массив из п положительных чисел . составить программу вычисления их : сред", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.