Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Помогите решить задачу в системе С, пожалуйста

10-11 класс

Den2818 04 февр. 2017 г., 0:37:04 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Wlastelina
04 февр. 2017 г., 2:17:04 (7 лет назад)

Реализация в языке С:

#include <stdio.h>

main(){
    int i,n;
    printf("Kolichestvo elementov="); scanf("%d",&n);
    double a[n],b[n],mean=0;
    for (i=0; i<n; i++){printf("a[%d]=",i+1); scanf("%lg",&a[i]);}
    for (i=0; i<n; i++){mean+=a[i];b[i]=mean/(i+1);}
    for (i=0; i<n; i++)    printf("b[%d]=%lg\n",i+1,b[i]);
}

Тестовое решение:
Kolichestvo elementov=5
a[1]=0
a[2]=1
a[3]=2
a[4]=3
a[5]=4
b[1]=0
b[2]=0.5
b[3]=1
b[4]=1.5
b[5]=2

Реализация в языке С++:

#include <iostream>
using namespace std;

int main(){
    int i,n;
    cout<<"Kolichestvo elementov="; cin>>n;
    double a[n],b[n],mean=0;
    for (i=0; i<n; i++){cout<<"a["<<i+1<<"]="; cin>>a[i];}
    for (i=0; i<n; i++){mean+=a[i];b[i]=mean/(i+1);}
    for (i=0; i<n; i++)    cout<<"b["<<i+1<<"]="<<b[i]<<"\n";
    return 0;
    }

Тестовое решение:

Kolichestvo elementov=5
a[1]=0
a[2]=1
a[3]=2
a[4]=3
a[5]=4
b[1]=0
b[2]=0.5
b[3]=1
b[4]=1.5
b[5]=2







Ответить

Другие вопросы из категории

Помогите пожалуйста!!
Дано два натуральных числа N и M.

Написать программу для определения наименьшего из чисел, составленных из цифр данных чисел. Незначащих нулей в найденном числе быть не должно.
Формат входных данных:
Входной файл INPUT.TXT содержит два натуральных числа N (10N10100) и M (10M10100), разделенных одним пробелом.
Формат выходных данных:
Выходной файл OUTPUT.TXT должен содержать найденное наименьшее число.

Читайте также

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите, пожалуйста, решить задачи.

1. В один из жарких летних дней Петя и его друг Вася решили купить арбуз. Они выбрали самый большой и самый спелый, на их взгляд. После недолгой процедуры взвешивания весы показали w килограмм. Поспешно прибежав домой, изнемогая от жажды, ребята начали делить приобретенную ягоду, однако перед ними встала нелегкая задача. Петя и Вася являются большими поклонниками четных чисел, поэтому хотят поделить арбуз так, чтобы доля каждого весила именно четное число килограмм, при этом не обязательно, чтобы доли были равными по величине. Ребята очень сильно устали и хотят скорее приступить к трапезе, поэтому Вы должны подсказать им, удастся ли поделить арбуз, учитывая их пожелание. Разумеется, каждому должен достаться кусок положительного веса.
Входные данные
В первой и единственной строке входных данных записано целое число w (1 ≤ w ≤ 100) — вес купленного ребятами арбуза.
Выходные данные
Выведите YES, если ребята смогут поделить арбуз на две части, каждая из которых весит четное число килограмм, и NO в противном случае.
Примечание
Например, ребята могут поделить арбуз на две части размерами 2 и 6 килограммов соответственно (другой вариант — две части 4 и 4 килограмма).

2. На клетчатой плоскости заданы координаты K зданий. Требуется построить кольцевую дорогу вокруг зданий минимальной длины в виде прямоугольника, со сторонами, параллельными линиям сетки.
Входные данные
Во входном файле, на первой строке, находится число K( ). На следующих K строках находятся пары чисел и – координаты зданий
( ).
Выходные данные
Выведите в выходной файл координаты левого нижнего и правого верхнего углов прямоугольника.

3. Хакер Иван является сотрудником крупной антивирусной компании. Один из вирусов исследованием, которого он занимается, был специально создан для атаки на программы биржевой торговли.
Для того что бы победить зловред Ване необходимо разработать алгоритм, который бы вычислил минимальное количество операций необходимых для того что бы пара чисел (a, b) стала "k -красивой". Пара чисел (a, b) называется "k-красивой" если хотя бы одно из чисел парны не меньше заданного целого числа k. При этом, операции, проводимые с парой чисел (a, b) могут быть только такие:
1. Пара (a, b) может быть преобразована в (a+b, b);
2. Пара (a, b) может быть преобразована в (a, b+a).
Помогите Ване победить.
Входные данные
Единственная строка входных данных содержит три целых числа a, b и k ( - 1018 ≤ x, y, m ≤ 1018).
Выходные данные
Выведите минимальное количество операций или число -1, если сделать заданную пару "k-красивой" невозможно.

4. Инженер-программист Надежда занимается разработкой компилятора для нового сверх секретного языка программирования. Для того чтобы закончить разработку одного из модулей ей остается решить задачу следующего содержания:
Во входных данных Надя получает строку содержащую в себе цифры и скобки одного вида: '(' и ')'. Наде необходимо написать программу, которая для любых входных данных определяет является ли содержащаяся в них скобочная последовательность правильной, и в случае правильности скобочной последовательности возвращает количество встречающихся в ней скобок, если же последовательность неправильная, то выводится число -1.
Скобочная последовательность называется правильной, если:
1. Пустая строка — правильная скобочная последовательность;
2. Правильная скобочная последовательность, взятая в скобки одного типа — правильная скобочная последовательность;
3. Правильная скобочная последовательность, к которой приписана слева или справа правильная скобочная последовательность — тоже правильная скобочная последовательность.
Помогите Наде в разработке компилятора для нового сверх секретного языка программирования.
Входные данные
Единственная строка конечной длины содержит цифры и скобки, длина строки не больше 1024 символов.
Выходные данные
Выведите количество скобок если скобочная последовательность правильная или число -1 если нет.

5. Маленький Вася научился считать сумму цифр для любого числа. Для любого числа, он считал сумму его цифр, затем тоже самое он делал с полученным в результате числом и так далее. Определите сколько раз Васе необходимо посчитать сумму, чтобы она стала цифрой.
Входные данные
Одна непустая строка с числом (0 Выходные данные
Одна строка, с числом.

ПОМОГИТЕ РЕШИТЬ ЗАДАЧУ ПОЖАЛУЙСТА.я пропустила тему. Дан одномерный массив А состоящий из 10

элементов.Вывести на экран исходную таблицу и резултат программы.

Найти произведения элементов массива А. удовлетворяющих условию:

c<=A[i]<=d.



Вы находитесь на странице вопроса "Помогите решить задачу в системе С, пожалуйста", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.