Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу которая считает количество чисел кратно 4 из промежутка от -80 до 145

5-9 класс

Bagira040886 24 сент. 2013 г., 13:55:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
122коля
24 сент. 2013 г., 15:40:59 (10 лет назад)

var

  i, count:integer;

begin

  for i := -80 to 145 do

    if (i <> 0) and (i mod 4 = 0) then

      count := count + 1;

  writeln('Count = ', count);

end.

 

 

//второй вариант

var

  i, count:integer;

begin

  for i := -80 to 145 do

    if i mod 4 = 0 then

      count := count + 1;

  writeln('Count = ', count - 1);

end.

 

//третий варинат

var

  i, count:integer;

begin

  i := -80;

  while i < 145 do

  begin

    i := i + 4;

    count := count + 1;

  end;

  writeln('Count = ', count - 1);

end.

 

+ 0 -
Лёха67
24 сент. 2013 г., 16:22:51 (10 лет назад)

var

  i, count : integer;

begin

  count := 0;

  for i := -80 to 145 do

    if i mod 4 = 0 then inc (count);

  writeln (count);

end.

Ответить

Другие вопросы из категории

Написать программу, реализующую стек на базе связного списка.

Реализовать функцию добавления элемента в стек и удаления элемента из
стек

Выберите логическую функцию, соответствующую функциональной схеме.

Объясните пожалуйста. Желательно подробно)

ПОМОГИТЕ!!!!! СРОЧНО!!!!!! ПОМОГИТЕ!!!!!!! СРОЧНО!!!!!!

Приведите примеры:
а) многозначных слов:
б) использование слов в прямом и переносном значении:
в) слов-синонимов:
г) слов-омонимов:
д) слов-профессионализмов:

Читайте также

Напишите программу, которая в последовательности целых чисел находит сумму и количество чисел, кратных 17, или сообщает, что таких чисел нет. На вход

программы подаются целые числа, количество введенных чисел неизвестно, последовательность заканчивается числом 0 (0 - признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введенные числа по модулю не превышают 300. Программа должна вывести сумму и количество чисел, кратных 17, или вывести NO, если таких числе в последовательности нет

Напишите программу, которая в последовательности целых чисел определяет количество чисел, кратных 4 и оканчивающихся на 0. Программа получает на вход целые

числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0-признак окончания ввода, не является членом последовательности). Количество чисел не превышает 1000. Введеные числа по модулю не превышают 30000. Программа должна вывести число: количество чисел, кратных 4 и оканчивающихся на 0.

Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел

в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – количество чисел, кратных 4.

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.



Вы находитесь на странице вопроса "Написать программу которая считает количество чисел кратно 4 из промежутка от -80 до 145", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.