Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

На день рождения Карлсона Малыш принёс в подарок большой пакет с конфетами. Малыш понимал, что никакой справедливости при разделе конфет от Карлсона

10-11 класс

ожидать не стоит. Поэтому он придумал игру, в которой ему обязательно должна достаться последняя конфета, а если повезёт, то и больше.Правила игры очень просты. Карлсон из общего пакета выделяет K конфет (K никак не меньше 3, но и, пожалуй, не больше 100000000). Играющие по очереди берут конфеты из кучки, причём за один ход каждый из них может взять от 1 до L конфет. Понятно, что первым ходить будет Карлсон, но он благородно уступил Малышу право определить максимальное число конфет L (2<=L<K), которое может взять игрок за один ход (в течение игры L не меняется). Малыш будет в выигрыше, если ему удатся взять последнюю конфету. Необходимо написать программу, которая помогла бы Малышу делать свой выбор числа L таким образом. чтобы последняя конфета всегда доставалась ему. Другими словами, по заданному числу конфет в кучке K необходимо определить такое число L, которое гарантирует Малышу хоть одну конфету. Так, например, если в кучке всего три конфеты, то победу Малышу обеспечивает выбор L=2. В самом деле, если Карлсон своим ходом заберёт одну конфету, то Малыш, взяв обе оставшихся конфеты, выиграет и, напротив, если Карлсон возьмёт две конфеты, что более вероятно, то Малышу достанется последняя конфета.Входные данные: Вход для этой задачи состоит из одной строки, в которой записано единственное число K - количество конфет в кучке, выбранное Карлсоном.Выходные данные: На выход следует записать единственное число L - максимальное число конфет, которое можно взять за один ход - обеспечивающее победу Малышу. Если таких чисел несколько, то следует вывести наименьшее из них. если таких чисел нет, то следует вывести число 0.Для проверки:Вход: 3; Выход: 2Вход: 7; Выход: 6Язык программирования: Pascal

147258369321 04 февр. 2014 г., 2:21:01 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Анжелика2033
04 февр. 2014 г., 3:01:45 (10 лет назад)

Ну так, вводим K, L:=K-1; выводим L. Тогда всегда остается последняя конфета

var K: integer;
begin
read(k);
writeln(k-1);
end.

Ответить

Другие вопросы из категории

Даны два действительных числа X и Y, не равные друг другу. Заменить меньшее из этих чисел половиной их суммы, а большее – их удвоенным произведением.

Разработать схему алгоритма для решения этой задачи. Протестировать алгоритм на числах 5.5 и -4.3, а также на числах 1 и 14.5.

Решать в Exel. Мальчик решил почистить аквариум. Начал с переселения рыб в банку,которых всего 40 штук.Первую он поймал быстро, затратив 5с, и ещё 2с

потратил на перекладывание в банку. На каждую следующую рыбку он затратил времени больше на 5%, чем на предыдущую. Сколько времени он потратил на переселение рыб?

Читайте также

все надо сделать в паскале. не было на теме, болел. помогите, завтра утром надо сдать.На день рождения пришли Н детей. Из них В

мальчиков. Сколько пришло девочек?

Составить программу вычисления функции:

Y= ((x+1)^2+2(x+1))/4
рассчитать для x=3.

винни пух и пятачок пошли на день рождения к ослику иа. каждый из них приготовили поздравительную открытку. открытка винипуха задержал 162 символа и

занимала объем 810 бит. открытка пятачка Занимала 852 бита и содержала 213 символов. чей алфавит содержит больше символов ?помогите очень прошу

Документ объёмом 8 Мбайт можно передать с одного компьютера на другой

двумя способами:
А) сжать архиватором, передать архив по каналу связи, распаковать;
Б) передать по каналу связи без использования архиватора.
Какой способ быстрее и на сколько, если:
• скорость передачи данных по каналу связи составляет 221 бит/с;
• объём сжатого архиватором документа равен 50 % от исходного;
• время, требуемое на сжатие документа, – 10 секунд, на распаковку –
3 секунды?
В ответе напишите букву А, если быстрее способ А, или Б, если быстрее
способ Б. Сразу после буквы напишите число, обозначающее, на сколько
секунд один способ быстрее другого.
Так, например, если способ Б быстрее способа А на 23 секунды, в ответе
нужно написать Б23.
Единицы измерения «секунд», «сек.», «с» к ответу добавлять не нужно.

Сколько целых страниц машинописного текста можно записать на магнитную дискету (считая, что никакой информации, кроме собственного текста, в файле не

хранится и одна страница машинописного текста примерно занимает 2,5 Кбайт), если:
Ёмкость (объём) дискеты: 1,2 Мб
Строк на странице: 40
Символов с строке: 60



Вы находитесь на странице вопроса "На день рождения Карлсона Малыш принёс в подарок большой пакет с конфетами. Малыш понимал, что никакой справедливости при разделе конфет от Карлсона", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.