Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

1. Дано натуральное число. Определить является ли произведение его цифр кратным числу A 2. Известны данные о количестве осадков, выпавших

5-9 класс

за каждый день марта. Верно ли, что осадков не было 10 дней в месяц?

ьфлы 01 февр. 2017 г., 2:03:18 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
гдсрф
01 февр. 2017 г., 4:23:39 (7 лет назад)

uses crt;
var ch,a:integer;
begin
readln(ch);
readln(A);
if ((ch div 10)+( ch mod 10)) mod a = 0 then
writeln('YES') else writeln('NO');


readln;

end.

 

2.

 


uses crt;
var i,os:integer;
a:array[1..31] of integer;

begin
randomize;
os:=0;
for i:=1 to 31 do
begin
a[i]:=random(5)+0;
if a[i]=0 then inc(os);
end;
for i:=1 to 31 do
write(a[i],' ');
writeln;
if os = 10 then
writeln('YES') else writeln('NO');

readln;

end.

Ответить

Другие вопросы из категории

ПЛИИИИЗ ПОМОГИТЕ


ПЛИИИИЗ ПОМОГИТЕ
НОМЕР1
Каккие признаки должны быть у
Каккие признаки должны быть у предметов и существ, которые (с которыми) выполняют действия? Выбери и впиши название признаков в каждую строку таблицы.
ДЕЙСТВИЯ :добавить ,проползти,опоздать .перекрасить


ПРИЗНАКИ:время,температура расстояние ,количество,скорость,цвет


номер 2
запиши название обратного алгоритма и допиши его команды .
1)Начало.

2)соедени насос с колесом

3)накачай воздух в колесо

4)отсоедени насос от колеса

5)положи насос на место

6)сядь на велосипед

7)конец

Найдите значение переменной y после исполнения серии команд (ЯП Паскаль):

x:=4; y:=5;
if x>0 then if y<8 then y:=sqr(x)
else y:=2*x+1
else y:=0;

Читайте также

Напишите программу на паскале)

1.С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.
2.С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.
3.С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.



Вы находитесь на странице вопроса "1. Дано натуральное число. Определить является ли произведение его цифр кратным числу A 2. Известны данные о количестве осадков, выпавших", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.